A weird Read More problem with no Excerpts

Hi Dear Moderator,
I have just started my blog on wordpress and luckily chosen Sparkling(2.3.2) as my first theme, Indeed one of the best wordpress theme. I have done necessary customisation according to my requirement. But finally stuck with Excerpt and Read more Issue. My front page is showing full content, Excerpts are not showing on front page of my website. Till now i have taken these steps but nothing worked so far-

  1. Checked SUMMARY box in Settings - Readings.
  2. Cleared Browser Cache and All History in all top 3 browsers.
  3. Excerpts with Read more Buttons are showing correctly when I preview website in Customizer (Appearance Section of Wp Admin)
  4. In Content.php file This Tag — <?php the_contentt(); ?> — is already replaced by — <?php the_excerpt(); ?> —

I have read all threads regarding this problem but still looking for an easy and reliable solution. I heartly appreciate all your efforts with which you patiently reply everyone’s problem.

Hi @ppsren,

I hope you are well today and thank you for your question.

You can display excerpts on the home page of your site by checking the theme option as shown in the attached screenshot.

Best Regards,
Movin

Hi Movin,
Sorry for this late reply. I would like to tell you that this option is already checked. For a better understanding, please visit the site http://www.jivansutra.com. Again, Thanks for your timely reply.

Have you made any changes in the theme files?

Please uncheck save - check and save again that option.

If it doesn’t work then would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

Hi Movin,
Yes, I made some changes in theme files including content.php (Line-15 <h2 class). For SEO benefit I made it a h1 tag. But that problem was persisting even with default h2 tag and default sparkling theme bundle. I also checked my site with travelify theme but there was no such problem. excerpts were showing well with travelify. just facing problems with sparkling. as per your suggestion, i checked-unchecked that option. excerpts are ok in customizer preview but not on live site. would it be safe to disclose login details here regarding security issues?

Hi Movin, After 3 days and a great struggle with repeated theme uploading, customization, wordpress settings, I finally got the solution of this read more problem. For others, I would like to tell that actually there is no need to make changes in Theme PHP files(not a single). Also, you don’t need to put CSS code in custom CSS through customizer. Nothing worked in my case as Read more buttons were appearing in customizer but not on live site. So, Just Check these 2 Things.

  1. Check ‘show post excerpts’ Check box and Remember to save it by going through Admin Area -> Appearance -> Customize -> Sparkling Options -> Content Options
  2. Check- Uncheck ‘Summary’ Option and then save it by going to Settings -> Reading -> Remember you may need to do this process 2-3 times, after that leave this ‘Reading’ Page altogether. You will probably get the desired solution.

Awesome great to see you got that resolved.

Please advise if you have more questions.

Have a fantastic day!