About and Services problem

i don’t know how to modific or add on About and Services.
If i try to add widget it can’t show nothing.
I have install all but not install Jetpack.
Jetpack need to activate or no problem about this?
Thanks so much.

Hi @elevatodue,

I’m having a hard time understand what the problem is exactly. Could you provide a screenshot of it ?

Colorlib support.

I am having the same problem. The options for all the Illdy widgets don’t show up when I try to customize my site. I can turn certain things off and sometimes they will turn off, but other times they don’t go away. The menu functionality is messed up as well. I turn off the header menu and it still shows up.

I attached a screenshot of what I see when I click to edit the About > Front Page - About Sidebar section.

Also, here’s a list of available widgets. Maybe this is the problem? Certain widgets (like the About widget) aren’t showing up.


I’ve been testing the About and Services and everything seems to work fine.
Inside the Appearances > Customize > About & Services, there are 2 different options.
The General Text, with the title and section content that goes above the widgets and the Front Page - Widget, where you can add content inside the predefined widget content.

You can use services widget in about section, for example, or add simple text widget or other from the list.
Once you finish with the setup of one widget, another one can be added.

I’m sorry if I’m missing the issue here, any further details would greatly help me to understand the problem and provide the according assistance.


The options for changing things like the percentages and the colors aren’t there, and I think it’s tied to the fact that certain widgets (like the About widget) aren’t even available to add to a page as seen in the third screenshot I provided.

I have same problem, there are no items under default Front Page - xxx Sidebar. I tried another hosting, older version od theme (1.0.7), but still same problem. What is missing?

I found this out after trial and error – you have to add the widgets where they go… You HAVE to add the about widget into the about section. You HAVE to add the project widget in the project section. You don’t have a choice. The widgets that show up when you first install the theme aren’t REALLY there – they’re just temporary placeholders until you put your own in there with real information. And you have to fill out all the information - even if you plan to eventually leave it blank. I first tried putting different widgets into different sections, but it doesn’t work. Good luck.

I’ve got the widgets under their respective areas and I have the checkmark toggled under Customize. But I’m still not showing anything on my home page. I have the page selected has my front page and the page type as “default view”. But still nothing. I’m also on the very latest update of Illdy. Any ideas?

Have you filled out the widgets - like uploaded your own content and filled out the forms?

Yes I have. I filled in placeholder text and picked random icons just to test and it still won’t show up. Do I need to change any settings on my home page itself? I tried “no sidebar” “left sidebar” “blog” and “default”. No luck.

The front-page is not a normal “page”… it doesn’t show up in your “pages” list. The home page is called “front-page.php” and it needs to be formatted through Appearance/Customize. You may want to delete what you have and start over? I don’t work for Illdy and I’m not a developer - just a user who figured stuff out on my own, so feel free to ignore me until someone of authority gets back to you. But if you delete everything and install fresh, select the Illdy theme, and then go to Appearance, Customize and fill everything out through that menu, it should work. Once you’ve got the basics set up that way, you can customize some of the details and any additional pages via the WordPress dashboard. Sounds like you’re not working on the actual front-page - but maybe the one additional page the Illdy theme comes with. Sorry I can’t be of more help. Good luck!

Hello @allisonaffourtit,

I already answered in the other topic of yours, I suspect you need to select “Your latest posts” inside Dashboard > Settings > Reading