Author bio

I wish to have a author bio at the end of each post (not pages). I’ve tried atleast 4 different plugins but in all of them the the author bio box displays without the profile pic ( gravatar or local).

I’ve also inserted the following custom css to avoid displaying sparkling default author bio box:
.author-bio { display: none; }

I’ve tried everything including clearing browser cache, uploading new image etc but nothing works.

Request your help finding a plugin or some solution where I can upload local image of author profile (not gravatar) and display an author bio at the end of every post.

Many thanks,

HI Fabadmin,

I hope you are well today and thank you for your question.

I don’t know the exact plugin that achieves it but you can search it on following pages or develop custom code to achieve this.

Best Regards,

Hi @movin,

Thanks. No matter what plugin I use, the author bio doesn’t display the gravatar image. I have the gravatar profile set properly with the same email id in both wp user profile and Don’t know what is the issue here.

It will be great if you can help with this.

Here’s the url for your reference:

If the plugin doesn’t help you to achieve the desired output then you have to develop custom code to achieve it.

Developing custom code for custom functionality is beyond the scope of support that we provide here.

If you are not a developer then you can consider hiring a developer to develop it for you. You can hire a developer from any freelance site. Colorlib recommends the developer

HI @movin,
I understand custom functionality is outside the scope of support here. You are not understanding the issue.

Not just any plugin, even if I use Sparkling default author bio, the gravatar image doesn’t show. I’m guessing this can’t be a plugin issue.

Hope this helps.

I have tested it on my test site and it’s working fine for me using latest version of Sparkling theme.

Please disable the plugin guerrillas-author-box that you are using on your site so that i can troubleshoot it.

Also please share me the screenshot of your user profile screen as shown in the attached screenshot.

Hi @movin,
Disabled guerilla plugin. Also attached user profile s/shot.

Please make sure to set the gravatar for your email id here

The gravatar is already set before I raised the ticket. attaching screenshot

The email id given in the gravatar and wp-admin user profile is also the same. I have mentioned these things in my earlier conversation too.

Hope this help.

Have you made any changes in the the theme files?

Please try deleting and reinstalling the theme.

This can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

If none of the above works for you then would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

Hi @movin,

Tried both your suggestions, plugin deactivation and theme reinstallation. Same result.
Here are the login credentials to my website

Site url:
uname: admin
pwd: x!j&H#CdzR6ajmwaug!oQvP4


Thank you for sharing the site details.

I logged in to your site and saw the Show Avatar site option was disabled as shown in the attached screenshot.

I enabled it and the Gavatar is displaying on your site now.

I’m surprise I missed that!

Thanks again @movin

You are always welcome here :slight_smile: