Background image Dazzling theme

I am having troubles with using backgrounds. The customer wants a lined background image which works perfectly. But then my pages are over this background making it hard to read. How can i make the background white?

http://www.tambinos.co.za/hire-equipment/

Hi @nelia,

I hope you are well today and thank you for your question.

I visited your shared page and it displayed for me as shown in the attached screenshot.

Could you please tell me where you want to make the background white on the page so that i can help you to achieve it?

Do you want to make the green image background to white as displayed in the shared screenshot?

Kind Regards,
Movin

Hi @Movin,
I actually just changed the background image to include white (not ideally what i want) as i didn’t receive a response to the post. Ideally i’d like the entire background the green stripes, but on the scrolling page to have a white background. so if you look left and right to the main section, it should be green lines.

Hi @nelia,

To achieve his could you please try adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Theme Options -> Other -> Custom CSS

div#page {
  background: url('http://www.tambinos.co.za/wp-content/uploads/2015/10/bg2.jpg') repeat transparent;
  background-size: cover;
}
div#content {
  background-color: #fff;
}

Best Regards,
Movin

@Molvin, This didn’t work… take a look http://www.tambinos.co.za/hire-holiday-toys/

Hi @nelia,

I visited your shared page and currently it’s displaying for me as shown in the first attached screenshot.

If you want to display it as shown in the second attached screenshot then please also use the following CSS code.

div#content {
  background-color: #fff;
}

Regards,
Movin

Still no luck, that code is also not changing the bg colour. If you look before the page loads, it flashes white, so i think it’s doing it, but then reverting to the full background?

Hi @nelia,

How have you used the provided CSS code as i don’t see it in the HTML source code of your site?

If for some reason the provided CSS code is not working on your site due to CSS specificity issue then you can try using the following CSS code instead.

div#content {
  background-color: #fff !important;
}

Regards,
Movin

Hi @Movin,

I’m using the “Simple Custom CSS” plugin. Tried the !important; and isn’t working either.

Maybe i should try a different plugin?

WOOHOOOOO! I tried a different CSS Plugin! And it works now! Thanks so much for your help! Day made!

You are most welcome here :slight_smile: