"Blog Full Content Display"-template not working


I’m currently setting up a website (on localhost) using travelify. I’ve created a blank page, set it up as the “posts page” and selected the “Blog Full Content Display”-template. However, it still only shows a part of the posts and the “read more” button. Is there perhaps a way to make it show the full post manually?

Kind regards,

I had this same problem. It seems to be that if you publish the blog page with a template other than the “Blog Full Contents Display” you can’t go back and change it to that template later. The way I solved the problem was by deleting the blog page (make sure you clear it from the trash too) and then creating a new page, this time choosing the full contents display template BEFORE I hit the publish button for the first time.

@AsaMariaBradley Thanks for your feedback and tips!

@Themrdjj in your case it might be that you are trying to set blog page via Settings - Reading - Post Page and obviously it is not going to work. leave that option blank and use proper Blog template via Page Attributes instead. The thing with “Post Page” setup is that it is going to use default blog template no matter what you add in the “Page Attributes”

Thank you for your answers!

I did all the things you both suggested and it works now.

Just to follow up on this thread. I changed some settings in my Settings->Reading Settings tab and the blog posts reverted back to not displaying the full content.

So, I think my previous answer worked not because I chose the template before I published, but because by adding more than one post page, the Reading Settings changed.

The key seems to be to not have the “Posts Page:” drop down menu set to a specific page. When I change that to the “–select–” option, all the templates I choose in Page Attributes work just as they should.

Thanks again for a great theme.