blog overview shows full posts


since the last update the blog page shows full length articles. i tried to change it with the wordpress settings but it didn’t work out at all. i also don’t have any additional css inserted.

i need help because it looks awful. here’s my page:

thanks, bellevie

I am having the same issue. Any way to fix this?

I’m having the same issue. Is there a fix?

I also have this issue at

Hello there,

I hope you are doing well today.

Could you please disable the Jetpack plugin or any other SEO plugin? As they may be negatively affecting the excerpt function in the theme?

Best Regards,

I’ve disabled the jetpack plugin and any other SEO related plugins, to no avail.

I have tried the above recommendation with no success.