Comments section not showing

I am setting up a new website, and I can’t get the comments section to show up on my page.

The site in question is As you can see, it is not possible to post a comment on any of the static pages. (‘Home’, ‘Het Plan’ and ‘De Fotos’). I verified comments on posts (that I have deleted to keep the site clean for now) do work, but I can’t get the static pages to allow comments.
However, when I use the Customizer (the real-time theme editing unit), I DO see the comments (see attached picture). But as soon as I click ‘save & publish’ (or whatever the correct translation is) and return to the normal site, the comments disappear.

Am I doing something wrong? I verified Customizer->Activello Options->Display Comments on Static Pages is on, all pages allow reactions, and the settings->reactions also allow for new reactions.

Thanks in advance for the assistance!

Best regards,

Hi Job,

I hope you are well today and thank you for your question.

I verified Customizer->Activello Options->Display Comments on Static Pages is on

Could you please just uncheck this option save the settings then check it again and resave the theme settings?

Also make sure the comments are enabled on your site and for the page as described on the below page.

Best Regards,

Hi Movin,

I have already fixed the issue by commenting out some lines in the theme’s page.php file (the if ( get_theme_mod( ‘activello_page_comments’ ) == 1 ) :, to be precise), which fixed the issue. I checked the theme’s code to find the issue and properly, but I couldn’t figure it out, so I went with the next best solution (commenting the problematic lines), which completely fixed the issue.
So, for anyone else having this problem, comment out the if-statement (and corresponding endif of course) and you’re good to go! It’s slightly hacky, but it works :slight_smile: )

Best regards

Awesome great to see you got that fixed.

Please advise if you have more questions.

Have a fantastic day!