Difficulty with installing Illdy theme update

A few years ago, after updating my site theme (Illdy) a number of times and experiencing no problems, I updated and my whole site went into a mess. So I re-installed a back-up and have avoided updating it since.

My site, www.shiatsu4u.com.au, is running on Version 1.0.29. The current version of Illdy is 2.1.9

It has now reached a point where I think I need to update (a few things aren’t working so well and there are things I can’t install because it is an old version) but am very nervous about doing it because of this history.

Back in 2016, I customized the theme directly. i.e. I didn’t make a child theme which I now understand I should have and that this is part of the problem.

My site is backed-up regularly and frequently but I am not particularly tech-savvy.

I’m looking for help on what my different options are and how I can go about this theme update with as little risk as possible.

Hi there

customizing a theme without a child theme is not a good idea, update will delete all your customization, check this tutorial to avoid that:

Many thanks for your reply and for the link - which I have now read. There are a couple of things that confuse me however.
(1) the use of “customized”, “edited”, “amended” (etc.) with respect to a theme. These terms seem to be both interchangeable AND to mean different things. Regarding my theme (& thence website), the only customizing I have done has been through the Customiser (within Appearance) on my WP Admin: putting in my content, images, links, etc. I haven’t directly edited any code - I wouldn’t know how to.
Does this still mean that my site has been customized?
I ask particularly as I noticed in the article you linked me to that the author says things like “if you have customized …” and “do you really need to customize …”. Which make me think some people don’t and yet everybody turns the original theme into “their” website. I also ask because prior to the theme update that created some problems, I had updated the theme a few times with no problems.
(2) With respect to updating and creating child themes when I have (maybe, probably) “customized” the theme what should I be using as the “parent theme” of which I make a copy to be the “child theme”?
It seemed as though I should be copying my site as it is now (already maybe “customized”) but then it also seems to be instructing me to customize the “child theme” as per my existing site. Why would I need to do this if it is a copy of my site?
Many thanks for your time, I look forward to your response.


  1. well, that’s not a customization, customization means editing theme files directly
  2. no need to use anything if you don’t have your theme customized, simply create a backup and update the theme :slight_smile:

Many thanks for that clarification. I have done as you suggested.
A number of issues did show up, most of which I have been able to sort out. There are 2 outstanding issues however that I haven’t figured out yet.
(1) the (anchor point) menu doesn’t work on either desktop or mobile versions. It doesn’t send you down the landing page scroll and it doesn’t allow you to return (from a call out page) to a specific place on the landing page scroll - just to the top “Home”.
(2) The banners - jumbotron and Blog (call out pages) "archive image - both images and site title - are completely blown up. So the images are indecipherable and the title goes over 3 lines.
I’ll continue to try and sort these things out but if you have any tips / directions that would be great.
Thank you very much for your help so far. I really appreciate it and particularly appreciate the speed of your responses.


Nice to hear :slight_smile:
let me see it, please provide a direct link to the website

The site is https://www.shiatsu4u.com.au
If you would like access into the site, let me know and I can give you what you need to do that.
I’ve spent some time investigating both the menu & the banners.
All the custom links in the menu are still in place and correct (as far as I can tell). They just don’t take you anywhere but back to the top (& only the top) of the landing page when you are in a blog post.
The banner problem persists - although I have experimented with changing the images and so forth.
With the Jumbotron in particular I’m completely stuck. That section appears to be locked and it reads: “Control various jumbotron related settings. Will only be displayed if a custom front-page is set in Settings → Reading.”
BUT when I go there, the only options I have are a “static” or a “display latest post” front page. It is set to “static”.

Very unfortunately, when I went into the site on Aug 7, I saw that some of the things I thought I had resolved had reverted to being problematic.
The problem started (after the theme upgrade) with the featured image on both blog/news pages and call-out pages in the “Projects” section not appearing. I used WP Optimiser to compress all my images (even though the Image Accelerator in Jetpack had supposedly been doing this). This seemed to fix the problem. Or, at least, in the Customizer version of the site it did.
When I went back to the site all the feature images were missing again on all the blog/news pages and, worse, the links from the landing page to the 4 Project pages were not working at all. I can no longer even click on them in the customiser.
I went into my most recent post - in “Edit” mode in the WP dashboard - deleted the featured image and then re-installed it. From that point I could open any post from the landing page on the customizer site and the image was there. But, if I looked on my phone or tablet or a different tab on my computer, they were not there. Even with much refreshing & opening/closing of the site over some hours.
I checked the 4 Projects pages from the WP dashboard and they are all there and their featured images as well. However, If I “Update” and “preview” the page, the image doesn’t show. (I haven’t tried re-installing an image yet.)
I checked the URLs on the Projects widgets and they appear to be unchanged. I didn’t want to delete them and re-install them (at that point) because I remember that it was tricky to get them to stick in the first place (i.e. 2016).

So those are my problems.
I have some questions about this updated version of Illdy but they can wait until I’ve got the problems fixed.
Many thanks.

Hi @barbarasydney

I’m so sorry but it’s really not necessary to provide so much information, it’s not a question now its a blog post I think, I only need a maximum of one or two lines of description of the issue, I only need to know what is not working at the moment,

" Will only be displayed if a custom front-page is set in Settings → Reading.”" - Yes, thats how it should work, it will only work if you set your static homepage from the settings > Reaing

Okay, too much info eh. Let’s take it one thing at a time then.
The anchor point menu (top right of landing page & call out pages) is not working fully.
It still doesn’t take you down the landing page to the sections specified in the menu, you just sit at the top.
[I have been working on it and the menu now returns you - if you are out from the landing page - to a designated place on the landing page: e.g. from a blog post to the Testimonials section.]
Can you help me with this please?


Well, that’s normal, thank you for understanding :slight_smile:

I’m sorry, but this problem was already reported and the developer will issue a new release soon with the fix

Apologies again. I saw (forum) that the menu problem was being looked at by the developers but thought it was just showing up in the mobile version - not for both mobile and desktop.

On another issue: the Projects Section has now got 2 distinct problems.

  • Links from the landing page to the 4 call out pages don’t work. (See message of 10 days ago)
    I’ve checked this on my phone because …
  • When I’m in the customizer, and I hover on the images where the links are embedded, I get a red circle with a bar through it and can’t even click on them.
  • I’ve also noticed that no matter which way I approach the projects sidebar widgets (via customizer or WP dash) I’m told that there is “no preview available” when there aught to be.

I could try sending the 4 Project widgets to the widget area and start again with clean widgets but this seems a messy band-aid type solution that doesn’t really address the problems. I’m hoping that you can give me an actual solution.
Thank you

[NOTE: URLs for images and for links embedded in images have been checked, removed & re-installed a number of times.]