Disable Comments ??


I have looked at your on line instructions to disable comments on pages and posts , they do not seem to be relevant…the images and tick boxes you show are not in my version of wordpress.

I have un ticked the show comments in the Screen Options on the page editor

I have selected the page…gone to screen options and un clicked comments on the show on screen option

I have gone to general setting - discussions and turned off everything to do with comments

I have looked at other posts on here on the same subject…which seemed to be not replied

I have seen your post on here and followed the instructions on the main word press site

NONE OF THEM WORK…All I want is my home page to look like the the demo one on your site and have comments off…?? I really cannot see where I am going.

This is a brand new fresh install…

Please help.


I made a video to make it as clear as it can possibly be:

It doesn’t matter what version of theme you are using, what version of WordPress you are using and what hosting you are using it is just that plain and simple


I downloaded a plug in that has fixed the issue.


You don’t need another plugin for a thing that you can do with WordPress default settings. Now you have bloated your website and your database that will eventually lead you to the next question - why my website is so slow? Try to use as few plugins as possible and this is the case where you definitely didn’t need a plugin.