Disable responsiveness for mobile devices for Travelify

I am using the Travelify theme for my website http://sandeepachetan.com

I want the the theme on the mobile to look just like it does on the desktop i.e I want the multi column layout and the menu bar to be seen (not the dropdown menu as it does right now).

I read your reply on another post saying the line <meta name=“viewport” content=“width=device-width, initial-scale=1, maximum-scale=1” /> to be removed. I did that, but it has not had any effect, I checked on a couple of android devices.

Is there anything else that needs to changed along with this?


Please ignore the question above.

I confused responsiveness with the mobile version of a site. What I did not want was the mobile version, which was activated in jetpack. I de-activated that, added the line to enable responsiveness back in the header-extensions.php file and it works fantastic on all the devices we have tested so far.

Except for one glitch. When the device is held in portrait mode or the screen is small enough to show only a single column layout, my menu items are not visible. I just see the 2 lines above and below the menu. The actual menu is blank.

Can you help me with what is going wrong?


Unfortunately. Your customizations (not ones done via WordPress customizer) have broken down theme functionality. You can see on our theme demo how it should work.

Personally, I would start clean to understand what went wrong. But before that, make sure to disable all plugins to check if this is actually your foul as there might be some script conflicts or something like that.

Very nice modification for this theme!

Hello Aigars

Removed all the customisations as you suggested, and added the changes one at a time. things seem to be back on track.