Doesn't honour max posts for home page

I’ve just installed the sparkling theme, however after setting the home page to blog style and setting the max number of posts to 5, I find that the number isn’t being honoured.

FYI, I’m using some stickies on the page too.

Hi @tonyd,

I hope you are well today and thanks for posting here.

I have tested it on my test site using latest version of Sparkling theme and setting reading settings “Front page displays” to “Your latest posts” and found it’s honoring the “Blog pages show at most” option setting.

Could you please share me your site URL and screenshot of Reading Settings so that i can troubleshoot it?

This can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine.

Kind Regards,
Movin