Don't show sidebar in the homepage

Dear Team,
I’m using sparkling theme.
I use also jetpack plugin for the visibility functionality.
I have a sidebar in each page but the one in homepage doesn’t appear anymore.

All started with a different image size of the slide show after an update of wordpress which caused a conflict with photon of jetpack: I disabled photon and the image of the slide show now is ok BUT (there’s always a BUT) the sidebar in the homepage doesn’t show up anymore, the other pages yes.

I have a sidebar with different widgets and for each widget where it is visible.
For home page -> no sidebar, no widgets
For the other pages -> yes

Strange, isn’t it?


Thanks in advance.

Hi Stefania,

I hope you are well today and thank you for your question.

I visited your shared site and the sidebar is displaying fine for me as shown in the attached screenshot.

Is it started working fine for you?

Kind Regards,

Dear Movin,

yes it appears but because I coded in header.php of the child theme.

Header.php line 82
<div class=“container main-content-area”>
<?php $layout_class = get_layout_class(); ?>
<!-- <div class=“row <?php echo $layout_class; ?>”> original →
<div class=“row side-pull-left”>
<div class=“main-content-inner <?php echo sparkling_main_content_bootstrap_classes(); ?>”>

My customer needed the website with all the links, therefore I checked what was the difference between the homepage and the other pages and I found it was the class applied to the container: row full-with instead of row side-pull-left.
Being a workaround I would like to understand what the problem is and act properly.



Please make sure you have not set Full Width or No Sidebar layout for the set home page as shown in the attached screenshot.

Dear Team,

I confirm it.

I have default template and right sidebar.


It’s working fine on my test site with that settings.

Would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

I will ask to the customer if she agrees to give you access to her website.
I suppose you need admin role, isn’t it?


Yes it is.