Error and Phone Number


There is this text on top of my workspace

" Warning: Creating default object from empty value in /home2/y6k7e6w9/public_html/wp-content/themes/illdy/inc/customizer/panels/general-options.php on line 21 "

How do i remove this ? It’s very annoying. I have tried to delete and reinstall and reactivated the theme but it’s still there.

I have also been unable to change and remove the “Phone: (555) 555-5555” to any number despite multiple attempts. Not sure these are related.

Please help. My website is

Thank you


Please excuse the phone number issue, we are just fixing this issue in the next theme update.
To fix this, please go to your FTp server and place the bellow code inside the functions.php in the Illdy root folder. You need to change the number inside the code snippet to match your phone number:

function change_phone_number(){
    set_theme_mod( 'illdy_phone', '(111) 555-5555' );
add_action('init', 'change_phone_number');

This will reflect in the homepage sections and also in the Customizing ▸ General Options ▸ Contact Details

The error you are getting seems to be related to the site title being an empty field, you can try to add a name for your website inside the Customize > General Options?

Let me know if this fixed your issues.



The phone number is now fixed thank you for your help !

However, i still cannot get the warning off the header still. My site title is filled up and has no problem.

Please view the attachment to see how it looks like.

I have looked online and people were giving suggestion to add this before the coding part. I’m not sure where to put it at.

if (!is_object($this->hidden)) {
$this->hidden = new stdClass;
$this->hidden->text = ‘’;


Please try to go on the FTP server inside the wordpress installation folder > wp-config.php file and change wp_debug to false, it might fix the issue:

define('WP_DEBUG', false);

Meanwhile, I’ll have the developers look into the problem and will provide you further information.


If this does not fix the issue, please update the PHP version to a minimum of 5.4.24


Did the developers ever fix this issue? I don’t want to disable debug mode, but I’m seeing the same message:

Warning: Creating default object from empty value in /wp-content/themes/illdy/inc/customizer/panels/general-options.php on line 21

Kind regards


Hello Alec,

This is still in development, please excuse the inconvenience!

Best regards