Error in WooCommerce

Hi,

Is Travelify new version compatible with woomerce? I’ve been using this theme with woomerce for about a year now and everything went well. Except last 2 months when I cant activate my woomerce.
Every time I will activate my woomerce, it will show this message.

“Plugin could not be activated because it triggered a fatal error.”

Hello there,

I hope you are doing well today.

Woocommerce is compatible with the Travelify theme. Please ensure that the theme and Woocommerce are both up to date. Another option is to reinstall Woocommerce.

Best Regards,
Support

I already tried to reinstall woocommerce in my plug in and it will prompt "“Plugin could not be activated because it triggered a fatal error.”

I hope you can help me how to fix this.

Hey there,
Switch to a default WordPress theme like twenty seventeen activate WooCommerce then reactivate Travelify.

Let me know if this works,

Best regards,
Support.