Fatal error in Illdy theme

I get this error when I activate the Illdy Companion. Anyone knows what to do?

“Fatal error: Class ‘Epsilon_Editor_Custom_Control’ not found in /storage/content/35/152435/juliadelin.se/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 345”


i also got the same error and cant seem to be able to log in to my customizer to make a few changes on my website any assistance will be highly appreciated ?

/home4/waeerw0ack56/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 453

Got the same error, even after updating the companion plugin… may someone help us?
I get the error when I try to customize the theme


Hi, I have the same problemI, after update Illdy I can´t open my website (http://www.fernandovacaflores.com) neither to have access to my wordpress.
I just have this message

Some help please

Thank you

Look I had your problem before, that’s how I fixed it (than find out another one but that are details…ahaha):

it’s important you have access to your website file (on the server)

  1. go to the file “wp-content/plugins/illdy-companion/illdy-companion.php” (you can open the file with programs as note and so one if you don’t have a coding software)

  2. go to line 70 and there you will have a fiew lines with:

require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-recent-posts.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-skill.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-project.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-service.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-counter.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-person.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-parallax.php';
require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-testimonial.php';
  1. change the last two to:
#require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-parallax.php';
#require_once plugin_dir_path( __FILE__ ) . 'widgets/class-widget-testimonial.php';
  1. save the file

after that you should have access to your website. (maybe not to the full but you should be able to do the last step)

  1. As last you have to update the illdy companion plugin when you go under “plugins” in your wordpress menu

And than all the things should work

Hope It is helpful :slight_smile:

Hi Sam,

Thank you for your answer. The problem is that I can not access to my website, look http://www.fernandovacaflores.com/wp-login.php

So I do not have acces to the file

Any idea??

Many thanks


ahh… sorry so you have no access to the files? You don’t host your website at bluehost or hostings like it?

I’m sorry, that was the only way I knew… by logging-in at “www.wordpress.com” and than under “plugins” update Illdy-companion?

I’m sorry I don’t have the solution

Having the same problem, I did what you suggested, samulibero and commented that last to require_one 's in “wp-content/plugins/illdy-companion/illdy-companion.php” . I don’t get the thing about updating the plugin after you made those alterations. The latest version of the plugin is now running so there is nothing to update…

Needless to say the error is still persisiting after those alterations. I can load the site, but can’t go into the customization settings anymore…

Hi stoofvless ,

actually the problem you have… the one in line 345 is the one I have too. If I don’t get wrong the two errors (ours and the one of negron) are two different errors.

Negrons has an error on line 70 that can be resolved by following the steps I wrote. By Updating the Illdy companion plugin to the v1.0.7 fixes the issue.

For the error on line 345 I have no idea on how to resolve it, cause it’s caused by a malfunction of these “Epsilon Editor Custom Control”… hopefully some moderator can give us an answer

Problem Fixed!

I removed the illdy companion plugin… cause I’m using theme called “total” made by others, illdy companion wasn’t compatible anymore

Thanks to all

Hey, Samulibero,

Thank YOU :slight_smile:

I came across this problem because I wanted to add projects to the theme like in the official video but pieces were missing and the official documentation says to get Illdy Companion going so maybe that was the culprit.

I too was wondering if just getting rid of the Illdy Companion plugin alltogether would be the way to go, So yes, the customizer works with me as well but still no ability to add project widgets. But that’s another issue for a another [Support request].

samulibero, were you working with Total because you gave op Illdy or were you working with Total anyways the whole time?

Hi @stoofvless,

That class is defined inside the theme, make sure you’re using the latest theme version.

Let us know,


Hi @laranz

I’m dealing with the same problem, just installed the theme yesterday. Can access the customizer when the Illdy Companion is unactivated, but I cannot change some of the text I need in order to set up the site. It shows a
Fatal error: Class ‘Epsilon_Editor_Custom_Control’ and ‘on line 345’. Could you advise how to solve this issue?


Hi @Laranz,

Actually I downgraded from the latest version (2.0.0) because 2.0.0 turned out quite buggy straight up. More details here: https://colorlibsupport.com/t/cant-edit-the-entry-of-the-project-section/

I have exactly the same problem as anneh90. Hope to get a solution soon.


I think there is either one of two options at the moment: or you hold on to the Illdy Companion and find a way around all the other bugs that come with version 2.0.0

or you roll back to an earlier version and forget about the companion plugin for now

I did the latter


Can you guys anyone shared your WP & FTP login details in a private reply, so that we can debug what is the issue?

Let us know,


Hi Laranz,

I tried a few things to fix it but still have the error (see below).
I cannot enter the wp-admin, only directadmin. What’s the best action to undertake? Thanks!

Warning: require_once(/home/buddyenko/domains/buddyenko.nl/public_html/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php): failed to open stream: No such file or directory in /home/buddyenko/domains/buddyenko.nl/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 70

Fatal error: require_once(): Failed opening required ‘/home/buddyenko/domains/buddyenko.nl/public_html/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php’ (include_path=’.:/usr/local/php56/lib/php’) in /home/buddyenko/domains/buddyenko.nl/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 70

Hi @buddyenko,

Try deleting the illdy-companion plugin via FTP and then reinstall that plugin again, it says that the /home/buddyenko/domains/buddyenko.nl/public_html/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php file is missing, so only it returns a fatal error.

Let us know,


This is a freakin’ nightmare!

2.0 erased my custom content from customization and when i roll back now this plug in gives me fatal error and i am unable to access any customization files.

i have tried everything regarding reistalling, deleting reinstalling, etc.

here is website www.communityisbrewing.org
user: [email protected] brewpon
pass: #Z0C8dbPYPjVIKP1LTFS#^W^

FTP access

[email protected]