Fatal Error When Accessing Customizer

Here’s what it says:
<<<Fatal error: Class ‘Epsilon_Section_Recommended_Actions’ not found in /home/dh_xyyieu/talkinginclass.org/wp-content/themes/shapely/inc/customizer.php on line 93>>>

Please advise. Thanks!

Hi there

Hope you are having a good day and thank you for your question :slight_smile:
Please reinstall theme, delete it completely and install it from appearance > themes and use the search
let me know if this method worked
Colorlib Support Team

Yikes. Is that the only option?

The last time I uninstalled and reinstalled, I spent forever redoing the tweaks that I had done to the site.

I’d really prefer not to completely reinstall. Might there be another more targeted approach I could try?

Hi there

Ok, then let me try it, please send me your access credentials along with your website URL and I will investigate this case. Don’t forget to mark your reply as private! Thanks!
Colorlib Support Team



Hi Matt,

You’re using old version of the theme, you installed it directly from github instead from WordPress themes directory? Go to Appearance -> Themes and update the Shapely, it will fix the issue.

If you did some code level changes in the shapely theme folder ( like editing any theme files ) I suggest you to convert the changes to the child theme, Child Themes « WordPress Codex read it here, if you don’t know what is a child theme, then after that continue the update, so that the code level changes you did will be intact after the update.

If you don’t want to update instead just want to fix the issue means, login to your ftp and move to /wp-content/themes/shapely/inc/libraries/ and remove the “epsilon-framework” folder, download this http://take.ms/S5gU5 and unzip it and upload this epsilon-framework folder into the place, that will solve the issue.

PS: Always take a back up, before doing any code level, just in case. :slight_smile:

Let us know,


Thanks for the help.

I tried setting up a child theme using the Child Theme Configurator plugin, which I’ve seen recommended many different places.

When I had it analyze my current theme, it spit out the following issues…

Notice: Array to string conversion in /home/dh_xyyieu/talkinginclass.org/wp-content/plugins/shapely-companion/inc/class-epsilon-framework.php on line 14

Notice: Array to string conversion in /home/dh_xyyieu/talkinginclass.org/wp-content/plugins/shapely-companion/inc/class-epsilon-framework.php on line 14

Notice: Undefined index: ampforwp-custom-type in /home/dh_xyyieu/talkinginclass.org/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 120

I see that two of the notices reference “epsilon-framework” as you did above, and the other one involves AMP (which I began setting up but eventually gave up on).

Thoughts on this?

And thank you for your patience with me on this!

Never mind on the last one. I just had to update two plugins and all is well.

Hello there

Is there anything else to this question? can we mark this ticket as a resolved?

You can mark it as resolved.

I do have another theme-related question, but it’s different, so I’ll just do another topic for that one.


Hi, there

Ok, thank you, I will now close the topic and mark it as resolved. Feel free to contact us again Thanks!