Favicon missing on some posts/pages

I have my favicon set in the site customizer. Here is an example of a post that has the favicon:
And here is an example of a post that is missing it:
And a page that is missing it:

Any ideas?


Hi @metallikat36,

I hope you are well today and thank you for your question.

I visited your shared URLs and the favicon is not displaying on any of those pages/posts.

Could you please make sure that you have configured it correctly and share me the screenshot of it?

I have tested it on my test site and it’s working fine for me using latest version of Dazzling theme.

Best Regards,

Screenshot attached. Note that the favicon image is set in the customizer, and that it appears on some of the browser tabs, but not all. The image is 512x512. Thanks.

I can see you are using cache plugin on your site so could you please try clearing cache from it or temporary disabling it?

Ya, I’ve tried that. I purge the cache on my CloudFlare and then deactivate it. Then I purge the cache on my Hypercache plugin and then deactivate. Then I still get the same result. Favicon appears on some pages, and not on others. At least from my end. I have left then deactivated so you can check on your end if you still don’t see any favicon.

It’s still not displaying for me.

Have you made any changes in the theme?

Please try deleting and reinstalling latest version of theme.

If it still doesn’t work for you then would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

I figured out the problem. I have a plugin that when I deactivate solves the issue. I have no idea why it is causing it, but I will contact the author. Thanks. Sorry to bother you.

Hi Movin. It seems maybe it is a problem with the theme. I am marking this reply as private with my login info:

login url:http://www.earthmedresearch.org/loginform
login ID: tempadmin
p/w: qxEs5*@696vedxXsN56h(LPa

I tried reinstalling the theme, but the problem is still there. I thought it had to do with a plugin, but the developer said this:

“As for overlay plugin - it has nothing to do with favicon whatsovever, it probably coincidence that you somehow see the icon after the install/uninstall, but it’s not there as it’s not part of HTML and http://www.earthmedresearch.org/favicon.ico returns nothing for me.”

On my computer, I can reproduce the problem with the following steps:

  1. Make a new post.
  2. View the post and note that it has no favicon
  3. Deactivate the plugin called “WP Smart Facebook Page Like Overlay, Pro”
  4. Reload the post and note that now it does have a favicon (at least on my computer…but the plugin developer says he still doesn’t see any favicon at this point)
  5. Reactive the plugin and reload the post, and note the favicon still shows (at least on my computer)

That’s all the clues I have.

sent you a provate reply.

Thanks for sharing the site details but it’s not working and i am getting the following error message on login screen.

ACCOUNT PENDING: Your account is currently not active. An administrator needs to activate your account before you can login.

This can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Hi Movin, sorry about that bad login info. If you could do me a favor and see if you see favicons all over site now?
I deactivated the plugin that I think is causing the trouble.

Yes i can see the favicon on your site now on all pages.