Featured Image Is Getting Transparent

Hello everyone, how are you?

Well, I’m getting the issue that when I enter in my site and click on posts and go to the post page, when I hover the mouse in the featured image she getting trasparent (opacity) I tryed many times and many codes to fix this and I don’t get any results with it.

Can someone help me?

Site: http://www.dietasedieta.com.br/

PS: The featured image on the index I managed to change with the tag .single-view, .blog-item-wrap { margin-bottom: 50px; background-color: #fff; border-radius: 4px; }

I don’t know how you tried to modify it but you have actually even increased opacity. You can eliminate it entirely by adding this code to Theme Options - Other - Custom CSS.

.single-featured:hover {
	opacity: 1;


I don’t want remove the opacity effect, I think is a great technique to pull attention of the people.

The problem is that I can’t set a background color below the featured image on the post page, in the index page I can set a background with the class .blog-item-wrap, why I can’t do this on the post page? There is no way to do?


You should either create a new div to wrap featured image or use this code:

.post {
    background: #fff;
	border-radius: 4px;

But this solution is not ideal in your case because you have separated author box from content area but this code will apply to the entire post and author box is part of it. There is no better selector available, so wrapping featured image or top part of the post with another div would be the best option here.