Featured Image not taking

Hello, If I create a page and set a featured image it continues to use the coffee image. I found the area where I can change the coffee image to one of my own however it then just sets this as my image as my header for all pages instead of my featured image.

Hi,

Go to Appearance -> Customize -> General Options -> Header and turn on this option " Enable featured image as header image " after that the header title bg image will be changed by the featured image instead the default coffee cup image.

Let us know,

Thanks,
laranz.