Featured Slider


I only want the featured slider to appear on the static home page. When I created my blog page the featured slider is also appearing on this page. I know I could hide it with CSS, but is there not an option to only show on home page?

This is common “issue” with this theme.

You have set “Front page displays” - " A static page (select below)" which is fine but you have also tried to enable blog via “Posts page:” which is not how it works with this theme.

You need to edit you blog page and select 1 out of 3 blog templates instead via Page Attributes. That way slider will remain on front page but no longer be visible on blog page.

Thanks, worked great