Front Page Title/Description Uneditable

When I try to change the “Clean.Slick…” and the description below those words, nothing happens. I can select the text but can’t delete it or change it.

Hello there,

I hope you are doing well today.

There should have been some text in the editor. Please try adding some text to the editor and the text should appear on the page.

Best Regards,

When I click on those boxes, the editor pops up, but there is no text, and nothing happens when I click in the box. Unable to type. This is true for all boxes labeled “entry” throughout the front page section settings. Please help!

I have the similar problem with megan10e, when I clicked on Title section, an editor opened, but I couldn’t see anything. Sometime I saw text, but when I edited, nothing changed on the homepage.
Please help!

Hey there,
Thank you for keeping in touch

  1. Have you made any recent updates whether WordPress or plugins?
    Kindly disable all of your third-party plugins and see if this issue still exists.
    If it resolves the issue I am going to then ask you to activate the disabled plugins one by one and test the page to see if we can isolate the conflicting plugin if that is the case.

  2. Try increasing your WordPress memory limit:
    You can contact your hosting for assistance if you’re not technically inclined.

  3. Is it possible for you to share with me the URL for you websites so I can investigate your the issue?

Best Regards,

Thank you for your quick responese.
I just updated wordpress ver 4.8.
I’ll try all solutions that you suggested and I’ll contact later.

My site is brand new, only three plugins: Akismet, Contact Form 7, and Illdy Companion- all of which came with the theme.

Hello there,

Please use the following plugin to clear out your WordPress cache then try to edit the content once more:

Best Regards,

That seems to have worked!

Thank you so much, it worked!