home page slider?

when i load my site, i see the slider; when i go to home (a page i set up with the template “blog image large”) - i don’t see the slider. how can i make it show here as well? thanks.

It might be much more difficult than you might think.

if( is_home() || is_front_page() ) {	
	if( "0" == $options[ 'disable_slider' ] ) {
		if( function_exists( 'travelify_pass_cycle_parameters' ) ) 
	if( function_exists( 'travelify_featured_post_slider' ) ) 

As you can see from this code above, slider is defined to work in homepage/front page. You can remove that part to make it work on all pages but here is another problem:

	if( ( is_home() || is_front_page() ) && "0" == $options[ 'disable_slider' ] ) {
		wp_enqueue_script( 'travelify_slider', get_template_directory_uri() . '/library/js/slider-settings.min.js', array( 'jquery_cycle' ), false, true );

Slider related scripts are also enqueued only on front page.

You can get rid of that as well but the main problem now is to get it work only on your blog page but since archive = blog you will make it work on all blog, archive (tags, category, date etc).

The best method is to move the entire slider related code from header-extensions.php to content-extensions.php and somewhere inside function travelify_theloop_for_template_blog_image_large

Personally I would just use some simple Flexslider based slider instead as it would be much more easier to implement by using a ready made shortcode.

I just checked your website.

You don’t need this page called “Home” you can just remove it entirely and add your actual front page as “Home” in menu via WordPress dashboard - Appearance - Menus. Since WordPress won’t provide this page to choose, it should be added as “Links”