How do I get sidebars on pages?

I can’t get a sidebar on a page unless its home or blog. Am I doing something wrong? How do I get a sidebar on a page that isn’t the home page and that isn’t a blog page or sub-page???

Slight correction. No I set it to display sidebars as default, but now I cannot REMOVE the sidebar from the blog page. Sigh.

Hello there,

I hope you are doing well today.

As I understand it, you were able to add the sidebar but now the sidebar appears on the blog page.

Please go to Appearance Customize > Unite Options > Layout options and set the website layout options to “No Sidebar” then check to see if the sidebar still appears on the blog page.

Best Regards,

Hey there,
I hope you’re doing well today

Please read through the following thread and apply the solutions here.
Before doing this be sure to do a backup of your site.

Best Regards,