how do i keep the logo from loading on all pages?

Activello theme.

domain: www.eveysreveries.com

my logo is loading on every page and i want it to loan only on the home page.

please advise.

Hi @eveytlh,

I hope you are well today and thank you for your question.

You can try achieving this by adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Customize -> Activello Options -> Other -> Custom CSS

#logo span.site-name {
    display: none;
}
body.home #logo span.site-name {
    display: block;
}

Best Regards,
Movin

Hi Movin,

I had a similar query and i came across this question.
I tried using this code in my custom CSS under Activello options; it didn’t work.

Is there any other code i could try?

@bishgop Could you please share me your site URL where it is not working so that i can troubleshoot it?

Here’s the site:

http://www.littlebighappiness.in/

I visited your shared site but didn’t find the above shared code anywhere.

Please make sure you are using that code in your site correctly. You can also add it in the style.css file of your child theme.

I removed the code because it wasn’t giving the result.

Please add it again so that i can troubleshoot it.

I added it back.

@bishgop I can see on your site that the logo is only displaying on home page and not on any other pages as shown in the attached screenshot so it means the code is working fine on your site.

Please test it clearing your browser cache or using different browser.

Thank you. Yes it worked. Now, I find that the tagline is visible. Please help me hide that too.

To hide tagline also you have to use the below CSS code instead of above shared CSS code.


#logo {
    display: none;
}
body.home #logo {
    display: block;
}

Thanks much. It worked.

You are most welcome here :slight_smile: