How to adjust length of posts

I am a novice and have no clue how to adjust the length shown of my posts. I forgot how I hid the whole post to only show the read more button, but I want to show an excerpt. I have seen the other posts regarding excerpts but do not know where to replace code. I tried to replace some code in the content.php but am afraid that I might have messed up something. Any help would be greatly appreciated.
here is the site


More information about content length, read more button behavior you can look into this thread.

Let me know if this helps.

Thanks Aigars. I seem to have the excerpt working now but no read more button. Not sure what to add to have that on all the posts.


You have completely removed “read more” button from your website and I am not sure how you done it, therefore you need to reinstall theme unless you know how you removed it. After reinstall no content or customizations done via Theme Options will be lost, so this process is harmless. It should bring read more button back.

I changed the theme in Wordpress and then activated the sparkling theme again. It still does not show the read more button. Is there another way to reinstall a theme?

Activating and reactivating is not enough. You need to switch to another theme temporary and then remove Sparkling theme completely. Then you can install it again like you did it first time when you installed this theme.

so I uninstalled the theme and reloaded it. I now only have the read more button and no more excerpt.

I don’t know where did you find this code but this code hides your post content on the front page. So make sure to remove it. I think you have added it inside Custom CSS field in Theme Options but I am not sure about that.

.home .entry-content p {
display: none;

That was the trick…thanks again for all your help, much appreciated.