How to display Travelify featured slider only on front page?

Thanks for the great them. I am new to all of this, and I cannot get the featured slider to only show on the home page. It is showing on my blog page and the home page. Is there any way to limit it to just the home page?

This is common appearance. To setup blog page don’t use WordPress built in blog feature that you have selected via Settings – Reading – “Posts page” but use theme built in blog templates instead.
Just edit your blog page and choose proper blog template via “Page Attributes” on the right side of Page edit screen.

Now you should see slider only on frontpage.

Thank you! That was a 5-second fix!