How to get lastest posts in homepage

I have changed my settings to latest posts and I do NOT have a static page, however, my recents posts are not coming up on my home page. I have also gone into theme options > under homepage post options, I have chosen the categories of which my posts are categorized and so far nothing. only two posts are shown on my homepage and no new posts are being published on my home page.

Also, my homepage posts (the only two that actually appear) look different from their appearance in the categories on my menu. I just want consistency on my site.

  1. Leave settings inside Settings - Readings to default ones by selecting " Your latest posts" option. Nothing more

  2. Leave Theme Options related to homepage to default ones as well. In your case you didn’t need to touch anything there.

I am still confused how you made it so messed up looking but first change above mentioned settings to default ones and let me know and we will continue from there.

The above mentioned is exactly as you stated and it is still the same. This is what it looked like when I activated the theme. I am at a stand still and don’t know where to go from here. I love your theme and it is exactly what I want.

Ok, then you will have to start from scratch with clean theme installation because some customizations have broken down theme functionality and there is nothing I can’t do about it. Just erase the existing theme folder and download it again from or our website. If you have some custom css inside Theme Options or other Custom CSS, make sure to remove it and start clean. If you changed colors via WordPress customizer then these changes will be there even after the reinstall.