How to get rid of error "Warning: Cannot modify header information" error

Hello again Algars,

I’ve came across this error when I try to add a post title. Is there anyway I can get rid off this error?

Warning: Cannot modify header information – headers already sent by (output started at /nfs/c04/h04/mnt/61941/domains/ in /nfs/c04/h04/mnt/61941/domains/ on line 876

I see that you use MediaTemple grid service because I had the same issues a while ago but I can’t remember what I had to change it order to make it work. Did you modify functions.php as it appears longer than the original one?
Will check for solution once I know more about this problem.

Btw, you are overpaying for bad service my friend. :slight_smile:
We can negotiate some deal on hosting if you are interested.

Hi Aigars,

I tried modifying functions.php in order to get my custom header to work but it wasn’t working for me so I gave up. I was able to edit the header_extension.php file though. I had not been able to get back to this site until today and now I am not able to even log into the admin. Could you please help?

Also, have you had a chance to update the error you had with custom header?

About Media Temple, have you not had good experience with them? We have been pretty happy with them. Don’t remember how much we are paying them monthly though. We are opened for other options though.


To get back on your website you should replace files you modified with original ones from theme installation. Most likely you did something wrong with some crucial files such as functions.php. I can’t say exactly what’s wrong without further inspecting your code.
You can check your hosting error logs for more information. You will see what files are causing PHP errors and notices and you can start digging from there.

I am terribly sorry about delay on custom header function. There is already part of code that does that but I have to re-style CSS and modify some HTML as well as hove to link everything together with WordPress customizer and Theme Options. Not as simple as it might sound :slight_smile:

Yes, tried replacing the file and it’s working like it was now. Thank you!
No worries, I was able to find the work around it :slight_smile: . Great work on the theme and support, btw. Look forward to see you other work!