Items displayed in portfolio

Good afternoon,

First of all, thank you for the theme, I love it :slight_smile:

I have a question regarding the items displayed in our portfolio. I have installed a plugin I found in a topic and our homepage now displays 16 items, which is what I want.
If you click the portfolio in the top right and get redirected to the portfolio page, it only shows 12 items. I would like this page to display a lot more items. So 16 max on the homepage and up to 36 on the portfolio page.

I hope my question makes sense and you can help me out.
Thanks in advance!

Kind regards,

Marion

Hello there,

I hope you are doing well today.

In order to change the limit, you may go to Settings > Writing > Portfolio Projects.
You will then be able to set the limit to any value.

Best Regards,
Support

Hello there! I tried this option and it did not change the number of projects displayed on the homepage. Any other suggestions?
Thanks in advance!

Same here. It used to work!
Following this thread.

I’m not sure if that option they’re referring to even works in normal pages now. I tested it on a dummy page and it didn’t limit my portfolio there either. Anyway, I found out where to set it manually. The number of portfolio images displayed is controlled in the Shapely Companion, not the theme. You’ll have to edit some code at this point.

Go to wp-content -> plugins -> shapely-companion -> inc -> widgets and edit the file widget-home-portfolio.php. Search for “per-page” and you’ll find the code " ‘posts_per_page’ => 10,". Just change that number to whatever you want, save the file, and you’re good as gold. Hope this’ll hold until there’s an update that fixes this issue for good!