Latest news button not working

My “More button” in latest news is simply taking me to the top of the page, not linking to a blog area. How can I correct this?


BTW - support here has been great!


This is quite a strange issue.

I suspect that you need to select your static blog page in Dashboard > Settings > Reading > Front Page Display.

Let me know if this was the issue and you got it fixed.

If not, please consider to provide me temporary admin dashboard access via a private message so I can have a live investigation.

Kind regards

PS: Thank you for the kind words and for appreciating my work!

I would just like to add, I was having the same issue and realized my blog was not selected in the aforementioned Settings page. This worked, thank you!