Latest Theme Update has screwed up theme customizer, Illdy Companion issues

After updating Illdy to the latest version, all sorts of problems have come up. Illdy Companion, upon activation, causes a fatal error, with the message below:

Warning: require_once(/home/content/01/5407801/html/angels/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php): failed to open stream: No such file or directory in /home/content/01/5407801/html/angels/wp-content/plugins/illdy-companion/illdy-companion.php on line 70

Also, the appearance customizer is completely screwed up, I’ve included a screencap of what trying to access it looks like. Since Illdy Companion isn’t activated either, it’s also impossible to change much else about the front end of the site. This latest theme update has changed what a lot of things looked like before on my site. The header and Jumbotron font is different, the yellow periods are gone, and the background color of the footer is black now. Prior to this Illdy update, I didn’t have any child themes or touch the theme’s code. My site is if you’d like to look for yourself.

Thanks for the help.

The illdy companion plugin is trying to use 2 files that for some reason are missing after the WP upgrade to the release 4.7.3. I’m used the following work around to at least put my site online without error messages however the look & feel is quite a mess.

To solve the error you need to edit the file located on /home/content/01/5407801/html/angels/wp-content/plugins/illdy-companion/illdy-companion.php and comment with # the lines 70 and 71 like this:

Hi there

I have what appears to be the same issue. Here is the warning message that appears whenever I attempt to open my website or access Wordpress. This message appears in place of either my website or the Wordpress site.

Warning: require_once(/home/nzbud825/public_html/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php): failed to open stream: No such file or directory in /home/nzbud825/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 70

Fatal error: require_once(): Failed opening required ‘/home/nzbud825/public_html/wp-content/plugins/illdy-companion/widgets/class-widget-parallax.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/nzbud825/public_html/wp-content/plugins/illdy-companion/illdy-companion.php on line 70

I have two questions:

  1. Is this the same error that mmweb reported and should I apply the same suggested solution that techbrain proposed?
  2. If not, what should be the solution here?

Thanks in advance

I’m experiencing the same problem. Is there a way to fix it completely without having to work around it?

same here. waiting for solution.

And about this?!
Not work for me:

I’m experiencing the same issue after the update…font changes, styling changes, lots of problems!!

PLEASE SOMEONE from colorlib help us out!

This is ridiculous, the site is throwing all sorts of PHP errors with this update. We need a fix, we have two people on this theme and it’s now broken and sites are down due to the problem. When will there be a fix. The fix above with commenting out the file works OK, however it doesn’t allow you to enter the customiser

Tried a few things to get this resolved. I can get it working to some extent but it just wont load the customiser. Whats going on guys?

yes all the customization are lost since they changed all the names and classes of the different objects.
Are you serious? One would expect a bit of grain of salt when pushing an upgrade to preserve compatibility.

I experienced this same issue. Luckily I was able to reinstall a previous version of the plugin, and I used the WP Rollback plugin to restore the previous version of the theme: WP Rollback – WordPress plugin |
Still experiencing some font and style issues. YMMV.

If I deactivate illdy companion I can use “customize” with older versions of the theme.

I had the same issue, solved it updating to companion 1.07 version and the new illdy theme 2.0. With that configuration it worked out. In order to get rid of the text fields which appear in the post of mmweb I deactivated some plugins and the fields disappear. I had problems to visualize the testimonial section but now it worked, I entered at least 2 testimonials (with one it will not work, dont know why) and upgraded the jetpack plugin. Hope that helps some of you!

The problem I have now is that responsiveness of the Title does not work anymore, title is completely screwed up in the mobile version (see first attachment) and in the testimonial section the text is not vertically centered (see second attachment). Some knows how to fix this?

I just updated our website to Illdy Version: 2.0.0 and I not able to use the customize feature any longer as it only displaying the widgets options (it wants me to Install the Kiwi Social Sharing WordPress Plugin, something I tried and didn’t fix anything). See attached screen shot.

I turned off all of my plugins to see if they were creating the issue and dumped the cache, nothing changed.

What can I do to be enable all the customize options.

Also, my child theme style.css was heavily affected, which from all of the articles that WordPress publishes regarding child themes is not supposed to happen.

Do I have to go back and rewrite my css code to fix this problem?


I had to install the kiwi plugin to make the theme work, try that first.

And I think you also need the last versions of the theme (2.0), of the companion plugin and the jetpack plugin.

When loaded the kiwi plugin the customizer changed slightly (see attached), still not able to view the complete customizer.

I am seeing the error message below after selecting the Customize option.

Uncaught SyntaxError: Unexpected token ,
at eval (<anonymous>)
at load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:2
at Function.globalEval (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:2)
at Ha (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:3)
at a.fn.init.append (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:3)
at Object.<anonymous> (load-scripts.php?c=0&load[]=underscore,customize-base,wp-a11y,wp-util,customize-controls,backbone,w…:10)
at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:2)
at Object.add [as done] (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:2)
at Function.<anonymous> (load-scripts.php?c=0&load[]=underscore,customize-base,wp-a11y,wp-util,customize-controls,backbone,w…:10)
at i (load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,jquery-ui-mo…:2)

Also, forgot to mention that I installed Jetpack 4.7 and I already had Illdy Companion 1.0.7

Will be anxiously awaiting a word from ColorLib on this problem