Link Hover Colour

Hello

I have hyperlinks in grey using the following code

}
#page .entry-content a {
color: #7c7c7c;

But the hover colour is black. How can I have no hover colour?

Thank you,
Lucy

Hi Lucy,

I hope you are well today and thank you for your question.

Just try using the below CSS code.

#page .entry-content a:hover {
color: #7c7c7c;
}

Best Regards,
Movin

Hi Movin

When I add the code, nothing changes and when I replace the code I posted above with your new code the grey disappears and it’s still black when I hover over the link…

Could you please share me your site URL where you are using the shared code so that i can troubleshoot it?

Hi Movin

I think you have misunderstood what I am asking for.

My hyperlinks are 7c7c7c

When I hover over them they stay this colour but with a black background.

I want to get rid of the black background so essentially nothing happens when the mouse hovers over the hyperlinks.

Thank you,
Lucy

Essentially I want to disable the hover so that nothing changes when the mouse hovers over a hyperlink.

Hello there,

I hope you are doing well today.

You can use the following CSS code to disable the link in the logo by going to Appearance > Customize > Additional CSS and pasting it there.


/*Remove hover effect*/
a:hover, a:focus {
    color: inherit;
    text-decoration: none;
}

If the code does not work, please notify us along with the link to your website.
Best Regards,
Support

Before I use this, just to be clear - I am not trying to alter or edit my logo.

When I have a hyperlink in the text of a post, I want to disable the option that colours the background of the text so that it shows as a black rectangle when the mouse hovers over it…

See my hyperlink is in grey. When the mouse is over it it shows with a black background. I want to keep the hyperlinks but disable the colouring of the background when the mouse is hovering over them.

Please try using the below CSS code and if it doesn’t work then share your site URL.

#page .entry-content a:hover {
    background: transparent;
}

Thank you, this works perfectly.

You are most welcome here :slight_smile: