Menu icon displays incorrectly on mobile

The hamburger menu icon in the header displays incorrectly on mobile. It appears that perhaps it doesn’t fit? so a placeholder icon is displayed instead. The same placeholder icon is displayed in lieu of the “return to top” icon in the footer. Both of these function correctly when tapped, but aren’t rendering properly in mobile. Any help is certainly appreciated.

Site address is: http://earthrisesolutionsllc.com/

If you open http://earthrisesolutionsllc.com/ and click F12 you will see errors (check attached image)

Check the other one that works, you have wrong configuration on server:
http://box5572.temp.domains/~earthri9/

Go to your settings in wordpres and add below lines to .htaccess file:

<ifmodule mod_headers.c="">
   SetEnvIf Origin "^(.*\.domain\.com)$" ORIGIN_SUB_DOMAIN=$1
   Header set Access-Control-Allow-Origin "%{ORIGIN_SUB_DOMAIN}e" env=ORIGIN_SUB_DOMAIN
   Header set Access-Control-Allow-Methods: "*"
   Header set Access-Control-Allow-Headers: "Origin, X-Requested-With, Content-Type, Accept, Authorization"
</ifmodule>

Hi there

tjkneale, I see this problem is resolved for you, can you please confirm if it’s resolved?

Thanks, nkulic,

I see that the http://box5572.temp.domains/~earthri9/ functions properly, but after adding the lines to .htaccess as you suggested, I don’t see any change to the behavior of http://earthrisesolutionsllc.com/.

Here is the entire .htaccess file:

BEGIN WordPress

The directives (lines) between BEGIN WordPress and END WordPress are

dynamically generated, and should only be modified via WordPress filters.

Any changes to the directives between these markers will be overwritten.

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg “access plus 6 hours”
ExpiresByType image/jpeg “access plus 6 hours”
ExpiresByType image/gif “access plus 6 hours”
ExpiresByType image/png “access plus 6 hours”
ExpiresByType text/css “access plus 6 hours”
ExpiresByType application/pdf “access plus 1 week”
ExpiresByType text/javascript “access plus 6 hours”
ExpiresByType text/html “access plus 5 minutes”
ExpiresByType image/x-icon “access plus 1 year”
ExpiresDefault “access plus 3 hours”
</IfModule>
<ifModule mod_headers.c>
Header set X-Endurance-Cache-Level “2”
</ifModule>
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /~earthri9/
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /~earthri9/index.php [L]
</IfModule>

END WordPress

<ifmodule mod_headers.c="">
SetEnvIf Origin “^(..domain.com)$" ORIGIN_SUB_DOMAIN=$1
Header set Access-Control-Allow-Origin “%{ORIGIN_SUB_DOMAIN}e” env=ORIGIN_SUB_DOMAIN
Header set Access-Control-Allow-Methods: "

Header set Access-Control-Allow-Headers: “Origin, X-Requested-With, Content-Type, Accept, Authorization”
</ifmodule>

I’m not a developer, but placed the new lines after ‘END WordPress’ based on the comments above. Not sure I’m doing this correctly.

Hi there

Well, this is what I see right now: Screenshot by Lightshot
The icon is appearing normally on my side

Hi, @Noda,

The menu icon was functioning properly on the http://box5572.temp.domains/~earthri9/ version, so, for example, if you clicked through to another page on the site, and then navigated back to the homepage, the site would take you to the temp.domains version, which was working fine (which is probably how you were able to find a version that worked), but the earthrisesolutionsllc.com version (the one you initially land on), still wasn’t working properly.

In the end, I was able to fix it by changing the WordPress Address and Site Address in General Settings to reflect the earthrisesolutionsllc.com address. It looks like this fixed the access control issues, and the menu icon displays properly throughout the site now.

Thanks @Noda and @nkulic for the help!

Thank you for sharing this information :slight_smile:

I will close this case now, Feel free to contact us again if you have other questions

Thanks!