Moving the search bar

Hello, and thank you for the wonderful theme!

I have some issues with the search bar. It works perfectly, but I think it just looks so big and massive at the top of the page. It messes up the style I’m going for. Reading through other threads on this forum I found the CSS code to remove the search bar altogether, and it works wonderfully. My problem is that I actually would like to have a search bar, preferably in the sidebar, but this CSS code eliminates all search possibilities. I even tried installing a search plugin-in, but that didn’t override the CSS code. How can I get a functioning search bar in the sidebar (but not at the header/top of the page)? Ideally I would like a small maginifier symbol or something more minimalistic, but I’d happily take just being able to move the search bar from the header and keep it as a sidebar widget.

The code I used to remove the search bar was:
.site-navigation-inner .nav-search {
display: none;

Thank you!

Hello there,

I hope you are doing well today.

Moving the search are would require the theme’s code to be rewritten by a developer so the best way to get the search feature into the sidebar is to use a search widget. You can use the CSS code to remove the search bar and go to Appearance > Widgets and add a the search widget to the sidebar .

Best Regards,

Hi, and thank you for your reply. Unfortunately none of those solutions work, as I stated in my earlier post. When I add the search bar as a widget to the sidebar, it’s completely blank and there isn’t anything clickable or writeable so it’s possible to make a search. I’ll post a screencap to show you what I mean. In case you don’t speak Swedish (who does outside of this country anyway?), it should be right there under “SÖK” but as you can see it’s completely blank.

The same thing has happened when I tried installing a search plugin-in. It becomes un-clickable, and therefore completely useless. It’s as if the CSS code to remove the search bar removes any possibility of having search possibilities on the site at all because, whenever I remove that CSS code I can add a searchbar wherever. Can you help me fix this?

Have a nice day!


Hey there,

Thank you for providing clarity.

Can you verify the search bar appears when using default WordPress theme such as Twenty Sixteen?
If the search bar does work, reactivate Activello.
You stated you’ve tried search plugins, please activate the plugin that shows but becomes is useless.
I’d like to test something.

Best Regards,

Hi, thanks for getting back to me.

The regular search bar works perfectly with other themes. I tried it with Twenty Sixteen and a few others.

As far as plugin goes I’ve tried two (neither are probably ideal for my purpose but I’ve struggled to find decent “normal” search plugins, probably since WP already comes with a search widget): Add search to menu and Relevanssi. The first one shows up as a little maginifier in the menu but is unclickable, the other might not even include a search bar (maybe it’s just for displaying results?); I can’t see it at all on the site. Both are activated right now.

Kind regard,

Please try deleting and resintalling latest version of Activello theme on your site.

This can be due to plugin conflict on your site so please try temporary deactivating all plugins except Add Search To Menu plugin and see whether the search icons displayed in the header works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Also you can try changing Search form style in the Add Search To Menu plugin settings in the admin area on the path Settings -> Add Search To Menu

Thanks for your advice. I tried both of your suggestions. No result whatsoever. Still unclickable :confused:

What’s next for me to try?

Best regards,

It’s weird.

Would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?



After logging in to your site i just reinstalled the activello theme on your site and the search in menu is working fine now as shown in the attached screenshot.

Oh yay! I thought I deleted the theme but I guess I just deactivated/activated it again. Thank you so much for the help!

You are most welcome here :slight_smile: