Multilang approach

I’m new to WordPress.
Using polylang I am able to translate the Illdy widgets in the different languages.
I read that there are also .pot files in the translation folder.

But I am still missing a way to translate the general text of the template.
Meaning i can’t find the general entry text of the about section in the .pot files. - As well as the general entry fields of the other sections (services, latest news etc.)

For the about section I ‘cheated’ (?) by not filling in the general section, but instead using the HTML widget. Like mentioned before I can make a widget for each language.

Am I missing something?
I guess the entry fields are dynamic and those fields are not available in the .pot files. The fields in the widgets are dynamic and I can translate those using Polylang.
But how do I translate the dynamic general entry fields of the template? It is not static (.pot), nor it is a widget…
They should be somewhere in the database and you should be able to translate those fields also?

Hopefully you can give me some insights!

Hello @jdehouwer,

I need to investigate the issue and gather some more information about the matter, so I’ll get back to you in the shortest possible time.

Which plugin are you using for the translation, qTranslate X or some other?

Best regards

Thanks for the fast response, I appreciate it!

I am using polylang as a wordpress plugin.

I havent tried any other plugin…

I have exactly the same question as jdehouwer below.
I am using the Illdy theme and the Polylang plugin to translate the whole website. However, I cannot find a way to translate the front page (About us / Services / Testimonials, etc).
Is there a way to do it?
I am also very new to Wordpress.

Many thanks

Could you already find any solution for getting the template to work in multiple languages?


We are currently conducting an investigation of the issue, verifying if it’s theme integration related, plugin or both.

I’ll return in a couple of days with more details and ideally a solutions on how to achieve the translation of the Customizer fields.

Please excuse the tardiness!
All the best

Hello @all,

We recently added some more fields to be translatable, what you need to do is to update the theme with the latest files:

Because polylang plugin does not offer support for the customizer fields, you need to use something like POEditor to generate the new .pot file and the equivalent translations.

I hope this is clear enough and will get you all further with the translation of the website.

We are still conducting investigations to see if other plugins like qTranslate X would be more user friendly.

Best regards

I worked perfectly!

Thanks for the support - super service!

Hi all,

I have the same issue as jdehouwer and aleari. I just wanted to check in if you guys have come up with solution on how to fix this.

Kind regards

Hello @carlius,

It seems like @jdehouwer managed to translate everything alright, so maybe he can give some insights about the plugin in used.

Like I already stated in the other message, the .pot file needs to be generated with the customizer content and then used inside the plugin.



It’s a little bit tricky…

First of all you must make sure that you do not make changes to the text fields within the customizer page of Wordpress.
If you do make a change to the default text using the input boxes, then your (modified) text will be submitted to the database and the .pot files will not be used to translate that textfield.

I use the Loco Translate plugin to do the translations.
But you can indeed use an exteral tool like POEditor to manage this outside your Wordpress installation.

Good luck!

I’ve same problem…
I am using also Illdy theme and the trying to use Polylang plugin to translate website.
But there is no any page or blog to translate and whenever i install polylang it chances my front page…
Besides, I cannot find a way to translate the front page (About us Services etc.) or ant other part of my site.
is there any way to do this?

I have a similar problem with WPML. I can translate “strings” , but the translated strings do not appear on the webpage - only in the backend. Even if I change the text using “customize” , the string in the string section of WPML does not reflect those changes.

Hello there,

If the changes are not being reflected on the live site but it is on the backend then you need to clear your browser or WordPress cache then reload the page to see the changes.

Best Regards,

i do not think this helps. anyway, how can i delete the WP cache. i don’t have any caching plugin.
Fact is: The customizing option overwrites entries that I make in the “translate string” screen of WPML. (i started another thread about that, so better talk about it there)

Hello there,

You can simply use a WordPress cache plugin to clear the cache. Here is a free one that you can use:

Best Regards,

Hi, i have the same issue.
How can I solve it?

When I translate my content inside the sections, it reflects to all languages…

Hi @guilhermedev,

Can you create a new support thread that has a detailed instruction to your issue? Along with the plugin you use and the steps you did, so that we can help you.

Let us know,