Newest blog posts now showing on homepage

Sorry, the title should say ‘not showing’.

My blog homepage isn’t displaying my most recent posts, despite the fact that they have published fine. It’s showing the latest post as being published on 17 April, when I have published 4 more since then. If you go down to the bottom of the page and click on ‘Older posts’, you can see my latest posts in the slider, but they’re not there on the homepage. I haven’t made any changes to settings or widgets recently.

The URL is

Hey there,
Hope you’re doing well today

Do you have caching enabled on your site? If so, I’m going to ask that you clear that. I’m also going to ask that you reach out to your hosting and have them clear the server side cache and see if that clears up the issue.

I hope this helps :slight_smile:

Best Regards,

No, I don’t have caching enabled on my site. I checked with my host and they said it was an issue with the theme.

They said that if you go to wp-admin → Appearance —> Themes —> Customize all of the posts are there, suggesting an issue with the theme itself. Does that make sense?

Hi there,
Thanks for keeping in touch with us.

Kindly disable all of your third-party plugins and see if this issue still exists.

If it resolves the issue I am going to then ask you to activate the disabled plugins one by one and test the page to see if we can isolate the conflicting plugin if that is the case.

Best Regards,

Thanks - I have tried that and it didn’t make any different. I have tried contacting my hosts again as I suspect it may be something they need to sort out. Thanks for your help - if you can think of anything else that I could try, let me know.

I can see the latest post on your site as shown in the attached screenshot.

Is the issue resolved for you now?

Yes, I contacted my hosts again and they realised it was a caching issue, which they fixed. Thanks for your help.

You are most welcome here :slight_smile: