only one post appearing on Slider

Hi there,

I deleted all the posts that came with the theme, and as a result seem to have deleted something related to the slider and it’s not populating my other posts, even though the category for sliders is on ‘all’ and slider is ‘on’.

The customised carousel buttons at the bottom and the arrows have also disappeared! But this was done via CSS. Does this mean it will re-appear when the slider adds another post?

Please help :slight_smile:

Thankyou,
Priya

Hi Priya,

Thank you for your questions.

I deleted all the posts that came with the theme, and as a result seem to have deleted something related to the slider and it’s not populating my other posts, even though the category for sliders is on ‘all’ and slider is ‘on’.

Could you please share me the screenshot of your slider settings and also share me your site URL so that i can troubleshoot it?

Also don’t set ‘all’ in the slider category instead create category for slider posts and select it there.

The customised carousel buttons at the bottom and the arrows have also disappeared! But this was done via CSS. Does this mean it will re-appear when the slider adds another post?

If the slider contains more than one post then it will reappear but will only display if you have not made it hidden using CSS code.

Best Regards,
Movin

Hi Movin,

Ah i see, thanks millions for your help,

Please find the relevant screenshots below.

My website url is:
http://priyarena.com/

Priya

In your shared screenshot I can see you have selected ‘All’ in the slider category. Please don’t set ‘all’ in the slider category instead create category for slider posts and select it there.

Your shared site is not accessible and just displays “Coming Soon” message so would you mind if i log in to your site and access it? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

Hey Movin,

Ah ok- so i’ve created a slider posts category. A little issue, now my posts on the homepage have that category displaying, please could you let me know how to keep it to the topic, for example it used to be ‘Travel’ for the Paris one.

Yeah sure, so my login details are:

Name: priyarena.com

Password: [email protected]

Thankyou!

I tried to login to your site using shared credentials but i couldn’t and got the error message “ERROR: Invalid username”

Could you please make sure that the shared credentials are correct and working?

Ah, sorry you have to do it through bluehost as that’s my hosting site, sorry I didn’t realise it means I can’t login through Wordpress. Those details I provided are correct :slight_smile:

I don’t want your hosting server details but your WordPress site admin login details.

Ah ok, sorry confusion!

so its my email address for login:
[email protected]
password: snoopy31

Now i am getting an error “ERROR: Invalid email address.” after using your shared credentials.

Nope that’s definitely it.

This is my wordpress email login (image):

Hi Movin,

Sorry there has been much confusion as I have only been accessing my site through Bluehost, and didn’t realise the wordpress login was something completely different - not sure why this happened.

But anyway, I can now confirm these details are correct for the login:

Username:
[email protected]
Password:
snoopy31

i just managed to get rid of the excerpt, so it’s just the slider issue now.

Thanks
Pri

The shared credentials are working fine for me now.

I logged in to your site and saw the Slider Posts category you have set for slider have two posts one having featured image and another without having it.

The slider only displays posts having featured image set so i have set dummy featured image for other post and it started displaying in the slider.

Could you please confirm?

Your blog seems interesting and i liked it.

Regards,
Vinod Dalvi

Hi,

I can confirm that is fixed thankyou, it would have been useful to know this earlier, sorry for the hassle!

Can I please ask,

I was told to create a ‘Slider Posts’ category for my slider posts - but my posts will belong to their own category for example ‘travel’. But now, on the homepage it comes up with the posts under both categories. I would like to hide the slider posts category, how can I do this?

Thankyou,
Priya

I can confirm that is fixed thankyou, it would have been useful to know this earlier, sorry for the hassle!

You are most welcome here :slight_smile:

Can I please ask, I was told to create a ‘Slider Posts’ category for my slider posts – but my posts will belong to their own category for example ‘travel’. But now, on the homepage it comes up with the posts under both categories. I would like to hide the slider posts category, how can I do this?

Answered in your following topic.

https://colorlibsupport.com/t/hide-slider-posts-category/#post-147950