posts content not appearing after latest theme update

Since the last update, my blog page shows the post excerpts but the individual post pages have no content.

Post page: https://comparativepolicy.org/deadline-extension-call-for-applications-to-mepp-program-at-ku-leuven/

Blog page: https://comparativepolicy.org/news-announcements/

Hi there

Hope you are having a good day and thank you for your question :slight_smile:
Can you try to activate one of the default themes and check your problem? let’s check it post content appears in a different theme, if this not helped please deactivate all your third-party plugins and check again,
let me know results
Thanks!
Colorlib Support Team

Thanks for the reply. I deactivated the plugins but the problem persisted and I tried a different theme and the post pages worked perfectly. So it has to have something to do with the latest Sparkling theme update.

Hi there

Can i take a look? please send me your access credentials along with your website URL and I will investigate this case. Don’t forget to mark your reply as private! Thanks!
Colorlib Support Team

Hi there. The access credentials are as follows:

Username: CScott
Password: Winifred9!

Thank you!

Hi @jrawlin,

In the child theme you override the single.php file, in around line #16 you have this line,

get_template_part( 'content', 'single' );

that cause the isssue, it should be like this,

get_template_part( 'template-parts/content', 'single' );

I tried to edit it, but it spinning for so long, I suggest you to edit that via FTP. ( Don’t copy paste the code form the forum, copy paste from your parent theme’s single.php )

Let us know,

Thanks,
laranz.

Thank you! That worked!

Hi, there

Ok, I will now close the topic and mark it as resolved. Feel free to contact us again Thanks!