posts not rendering - using read more button

We have setup a new website using your Illdy theme as the basis (which we really like) but have run into a problem. Any posts we create will show up as excerpts/lists on the blog page (news) but the actual posts will not render - if the “Read more” button is pressed a blank page is shown and not the actual post.

our site is

we have set up a test post on the live site

and we have tested it on a local version of the site (using MAMPon a mac) with the same problem. (hence not a server issue.
We have also tried disabling all the plugins but the same problem occurs.

Any advise will be gratefully received.


You should try to resave the Permalinks options in Dashboard > Settings > Permalinks, it might do the trick.
On top of this, it seems to me that you are not displaying the homepage alright, since you should select a blank page for the front page display in Dashboard > Settings > Reading.

Let me now if resaving the Permalinks did the trick.


Thank you for your prompt reply.

I have tried re-saving the permalinks but

when viewing the post page

it still is blank.

Can you think of any ideas why this is the case.

many thanks

Following further investigation I found a forum suggesting;

“PHP setting being too low. The setting is the pcre.backtrack_limit directive which by default is set at a low ‘100000’.”

I created the PHP.ini file with the following content


and uploaded it to the public.html folder on the server.

I then checked the post page and the following error was returned

“Parse error: syntax error, unexpected ‘<’ in /home/halesmar/public_html/wp-content/themes/illdy/single.php on line 8”


The error states that there’s some extra symbol in the single.php file.

Have you done any modifications to the core files?

You might want to re-add the default theme files on your server to get your website back.

As for the php.ini, you should check out the Cpanel if it’s offering this options or better contact your hosting provider.

If nothing works, additionally you could provide me temporary login details to have a look for myself.


Thank you for your help I reinstalled the theme and all is working again.

I think the problem was when I had looked at the options for Yoast SEO I activated the breadcrumbs function and then deactivated it but this had updated the single.php page stopping it from working.