Previous/Next post navigation skipping entries

Previous/next post navigation for my latest post is skipping the previous post and going back three posts before that one.

The previous post (the one before the latest post) does not show a next post link at all.

I just updated to WordPress 4.7. Any idea of this created the problem, or could there be another issue?

I’ll provide a site link privately if an admin would like to check it out.

Thanks!

I have to tell you, this is almost certainly an issue with the Sparkling theme. I tried several of the default WordPress themes with my site, and post navigation performs flawlessly.

You’re going to have to fix this, Colorlib – ASAP.

Further, this is not your first navigation screwup.

You still haven’t fixed this one:

https://colorlibsupport.com/t/pagination-3/#post-74309

Hi @slobjones,

Sorry to hear of the problem you are having.

Could you please share me your site URL where it’s happening so that i can troubleshoot it?

Further, this is not your first navigation screwup.

You still haven’t fixed this one:

https://colorlibsupport.com/t/pagination-3/#post-74309

The issue is already fixed in the github version of theme which can be downloaded from GitHub - FreeWPTP/Sparkling: WordPress Bootstrap 3 theme with doeznes of options powered by Options Framework

The changed theme is waiting to get reviewed so that it will be available on WP.org

Kind Regards,
Movin

Movin:

Here’s my site:

Thanks for your assistance.

I couldn’t confirm the issue on your shared site so could you please share me the screenshots of the issue?

I couldn’t confirm the issue on your shared site so could you please share me the screenshots of the issue?

No need to overcomplicate things with screenshots.

Just look at the site.

Here’s the second-most-recent post: http://www.unitedhebrewth.org/what-are-your-gifts/

Scroll down to page navigation and notice it’s not linking to the previous post, which would be this: http://www.unitedhebrewth.org/temple-israel-highlights-farringtons-grove-holiday-home-tour/

Instead, it’s going back five posts, to this: http://www.unitedhebrewth.org/awake-and-sing-is-a-worthy-production-if-not-quite-kashrut/

Again, if I change from Sparkling to one of the default WordPress themes, the navigation works just fine.

I could confirm the issue on your site but it is working fine on my test site.

This can be child theme issue on your site so to confirm it just temporary use the Sparkling theme instead of child theme on your site. If everything works fine then it’s your child theme issue so just share me your child theme so that i can troubleshoot it.

Also this can be due to plugin conflict on your site so please try temporary deactivating all plugins and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Movin, thank you for verifying the navigation error.

However, as I stated earlier, the error occurs only in Sparkling. Yes, it occurs with my Sparkling child theme as well, but the issue originates with the Sparkling parent theme and occurs when I select the parent theme.

It does NOT occur with any of the WordPress default themes, such as 2015. I’ll provide screenshots privately.

I’ve tested plugins. The issue is NOT plugin-related.

The issue is with the Sparkling theme. Please alert the developers.

Movin:

I’m attaching screenshots.

The first shows navigation with the Sparkling theme, pointing to an entry five entries back instead of the previous entry.

The second shows the 2015 theme, with navigation working correctly.

Again, the problem is with the Sparkling theme. It’s not with my child theme, it’s not caused by plugins.

Please alert the developers.

Thank you.

As said previously i could confirm the issue on your site but it is working fine on my test site using same version of Sparkling theme so how can i confirm that it is the Sparkling theme issue?

It is only happening on your site and not any other so there must be something related to your site.

If possible please temporary use parent Sparkling theme and deactivate all plugins on your site so that i can troubleshoot it but if it is not possible on your live site then do this on any other of your test site or create temporary one.

Clearly, the navigation issue is not going to occur every time on my site or on your site.

As I’ve established, it DID occur on my site, ONLY with the Sparkling theme, NEVER with other themes, and continued to occur with the Sparkling theme, with plugins disabled.

I can hardly disable all plugins and change themes on an active site while you putter around with it.

I’ve shown you the problem. If you don’t want to report it to the developers, that’s on you.

And I’ll certainly take that into account while developing sites for clients in the future.

I can’t report the issue until i reproduce it.

I could confirm the issue on your site but this may be because of the code you have developed in your child theme so i asked you to temporary disable it.

I know you can’t do this on your live site so already told you in my previous reply that if it is not possible on your live site then do this on any other of your test site or create temporary one.

You are not doing any of this so i can’t reproduce and report the issue but if still want to report it then you can do it yourself by reporting it on the below page.

Once again, I would encourage anyone experiencing the post navigation issue to report it on this forum.

The developers must acknowledge the bug and address it. Unfortunately, they continue to ignore it.

Movin: I’ve rolled Sparkling back to version 2.2.2. Navigation is working correctly now.

This confirms that navigation is broken by Sparkling 2.3.2. I would appreciate it if you would finally acknowledge this fact so the developers can isolate the issue and correct it!

This only states that the code you have developed in your child theme is conflicting with current version of theme and not old one but this does not conclude that the issue is in the theme.

The only way to conclude it by the way as described previously in my following reply but you didn’t do it yet.

https://colorlibsupport.com/t/previousnext-post-navigation-skipping-entries/#post-80828

You’re just screwing with me now. I can see that.

As I told you, the issue occurs when I use Sparkling 2.3.3 WITHOUT the child theme.

When I switch to Sparkling 2.2.2s or any other theme, the navigation issue GOES AWAY.

Your “request”, clearly designed to create so much work for others that they simply go away and stop making you try to do your job, is for me to create an entirely new website that is somehow going to reproduce the problem for you.

Appalling.

I’ll take clients far away from Colorlib from now on.

Here’s the following your previous reply which clearly doesn’t say WITHOUT the child theme.

Movin: I’ve rolled Sparkling back to version 2.2.2. Navigation is working correctly now.

This confirms that navigation is broken by Sparkling 2.3.2. I would appreciate it if you would finally acknowledge this fact so the developers can isolate the issue and correct it!

Let’s see what the developer say on your following posted issue.

At this point I’m just going to presume you’re not actually human, but a malicious bot designed to waste the time of theme users so Colorlib doesn’t have to provide technical support.

To repeat: Absolutely appalling.

Update: At long last, the theme developer has acknowledged the pagination issue in 2.3.3 as a BUG.

Let me note that Movin’s concerted efforts to deny the issue’s existence rather than reporting the bug when I pointed it out months ago unnecessarily delayed this process.

Colorlib users can only hope that these support forums will be more responsive in the future to reports of issues with their themes.