Problem disabling widgets for Dazzling WordPress theme

Hi there,

I’m having problems getting rid of widgets I don’t want, namely ‘Archives’ and ‘Site Admin’. They don’t appear on the front page (which is great) but they appear on every other page. Also, on the front page my menu appear also at the footer which I don’t want and isn’t set up to do. Hope someone can help.

Hello Helene, thank you for contact us.

In order to stop displaying any widget from your site, follow this instructions:

1- Login as administrator to your website dashboard.
2- Once on your dashboard go to the Appearance section and from there select Widgets
3- On your right side of the screen you will see a box that says SIDEBAR, in this box you will see are the widgets that are displaying on your website Hompage, Pages, Posts, etc…
4- In order to stop displaying the Archives and Site Admin widgets, all you need to do is to select any of them and with the mouse button pressed down, drag the widget to the bottom part of this page to an area called: Inactive Widgets
5- Once you have the widget there, release the mouse button and you will see that the widget is showing below Inactive Widgets, but not on the Sidebar area.
6- Repeat the process with any other widget you don’t want to display.
7- Then go to your website and refresh (reload) the page, you will see that the widgets are gone.

Regarding the menu showing on the footer, please follow this steps:

  1. 1- Login as administrator to your website dashboard.
    2- Once on your dashboard go to the Appearance section and from there select Menus
    3- Here you will see on the right side a box that says Menu Structure with your menu below this tittle. Below the menu you will see Menu Settings there is an option that says: Footer Links under Theme Locations.
    4- Un-check that option and click on the Save Menu button to apply the changes.
    5- Refresh your website and the menu on the footer should have gone.

Please do not hesitate to contact us if you have any other questions or concerns.


Hi Nelson,

Thank you for your help. I actually have done all of the above and I still have these problems.
In widgets, the only ones I have active are “custom menu 1” under “Homepage Widget 1” and “Custom Menu 2” under “Footer Widget 1”. There are no widgets listed under sidebar in widgets. Yet, “Meta” and “Archives” appear in the sidebar of all my pages except for my home page.

Same for my problem with the menu. Under “Menu Structure” I am at “Menu 1” I have checked off “Primary Menu”. “Footer Links” if left unchecked and it even says next to it “currently set to: menu 2”. Yet, on my home page menu 1 appears in the footers. But only on the main page.

Hello again Helene, could you provide us with the link of your website?

Hi Helene, thanks for the link.

Could you please check on the widgets area in the dashboard all if by any chance, the Archives and Meta widgets are in there?

Happened to me, that while I was trying to drag the widgets all way down to the Inactive Widgets area, I drop them by mistake on other boxes: Homepage Widget 1, 2, 3, and Footer Widget 1, 2, 3…



So I double checked that and I don’t think that’s the case. I’ll describe that I see and what I’m doing:

-I go to Appearance> Widgets.
-Under “Available Widgets” is Archives, Calender, Call to Action Placement…, Call to Action Static, Categories, Custom Menu, Dazzling Popular Posts, Meta, Pages, Recent Comments, Recent Posts, RSS, Search Tag Cloud, and Text.
-I drag Archives to under “Inactive Widgets”. I successfully drop it there and it stays under Inactive Widgets. But Archives also still remains under “Available Widgets” (so there is an Archives under Available Widgets and an Archives under Inactive Widgets). Same steps and results for Meta.
-To the right I see Sidebar, Homepage Widget 1,2,3 and Footer Widget 1,2,3
-I click down on Sidebar and its blank (which I want);Homepage Widget 1 has “custom menu”; 2 and 3 are blank; Footer Widget 1 has “custom menu: menu 2”; 2 and 3 are blank.
-I go to my website and reload the page. There is nothing in the side bar of the main page (which is what I want). I click on the next page and Archives and Mata are in the sidebar. This is the same for all other pages (except my contacts page in which Archives and Meta appear at the bottom of the page).

The front page also still has the main menu listed in the footer even though it’s not selected to appear there.

I hope this can get solved!


Any suggestions?


On your website I see only two widgets: one is the footer and one in the sidebar and both are two different WordPress Custom Menus and I don’t see any Meta or Archive widgets like you are describing. Maybe that’s some local cache issues for your web browser.

Also, widgets that you drag from available widget section inside Appearance - Widgets are not completely disabled but they are just saved for later use. For example, you can create a custom configured widget and save it under Inactive Widgets and always reactivate it using your custom settings.

Let me know if this helps.

I have the same problem. I kicked out all widges im using none right now, but there are still those two left (archives, meta)


I see that you have already figured that out.

Let me know if there is anything else.