Remove photo title and info from Jetpack carousel

Hi Movin,

I’m hoping you can help me with this issue even though it is a Jetpack plugin question, or point me in the right direction.

I’m currently using Jetpack tiled gallery in my posts. However, when I click on the image, in the carousel, it shows the title and which camera+aperture I used on the bottom of each photo. Also in mobile view, the title appears on top of the photo.

How can I hide this info for all photos? I’ve attached screenshots.


Hi Vanty,

I hope you are well today.

Could you please share me the page URL from your site where it is displaying so that i can help you to remove it?

Kind Regards,

Hi Movin,

Thanks for your response.

My url is:

Thank you for sharing your site URL but do not just share your site URL please share me the page URL from your site where it is displaying.

Hi Movin,

Oh sorry for that!

The page url is

But it’s all carousel displaying the photo galleries on every post.

Many thanks,

You can try removing it by adding the following CSS code in the Custom CSS option of your theme on the below path.

Admin Area -> Appearance -> Customize -> Activello Options -> Other -> Custom CSS

.jp-carousel-info {
    display: none;

Hi Movin,

Thanks for the code! It works perfectly on the desktop version.

However, the title info still shows in the mobile version. I tested it from my cellphone and indeed the title is there.

Please advise.


Hi Movin,

I hope you are well these days. I’ve been trying to figure out what the problem with the mobile site is and trying different css codes to hide the image name and then I realize the entire “mobile version” of my site is messed up, i.e. not updated with most of my changes. But when I click on “View Full site”, everything is perfect just like on the desktop version.

Is it possible to disable the “mobile version” so that when people go to my site url from their smartphones/tablet, it automatically takes them to the “Full site” version? That would resolve a lot of issues.

Many thanks,

Hi Movin,

I finally resolved the issue by turning off Mobile site on Jetpack!

Awesome great to see you got that resolved.

Please advise if you have more questions.

Have a fantastic day!