Setting Featured Image on Pages

I’m having an issue setting a featured image on any of my pages. I am using the illdy theme on www.celestialcakery.com without little issue, but on www.swirlclt.com I can’t set a unique page featured header image. It keeps reverting to the “blog archive header image” instead of the featured image selected on the individual page.

From what I’m reading on the support forums this isn’t possible unless I change the header image for each page manually via Custom CSS? see below

Appearance -> Customize -> Additional CSS,

.page-id-12 #header {
background-image: url(“http://lorempixel.com/400/200/”) !important;
}
where 12 is the Page ID you want to change the header image, and give the image URL.

But that’s not true… I know its possible without adding css code. I have already have a different header image for every page on www.celestialcakery.com but for some reason, I can’t get the featured image to change for each page on www.swirlclt.com despite them using the same theme. I look forward to any insight the community can give, thanks :slight_smile:

Hello there,

I hope you are doing well today.

You need to ensure that the featured image you are using is large enough to span the width of the the page, also try removing the image from the blog archive via Appearance > Customize > Blog Options > Blog Archive Header Image.

Best Regards,
Support

The image I’m using is 3000 pixels wide which is more than enough to span the width of the page.

1 - I resized my photo to 1920 x 532 which is the recommended illdy image header size and nothing changed.
2 - I disabled all plugins and nothing changed.
3 - I removed the image from the blog archive and all that did was swap the coffee cup for a solid color background instead of showing my featured image as the page header.

Again, I’m not new to the illdy theme. I use it with little issue on www.celestialcakery.com where every page has its own unique header image. This is only a problem with the illdy theme on www.swirlclt.com which is setup the same as the previous site. Is there another option available to resolve this?

Hi there,
Thanks for keeping in touch.
In this case, could you kindly provide us with temporary admin access to your WordPress Dashboard so that we can have a closer look into this.

You may create a new administrator user within your WordPress Dashboard using your email address. You may then copy the login credentials to us in your reply.

I look forward to your reply.
Best Regards,
Support,

I have created a temporary admin login.

username - colorlib
email - [email protected]
password - [email protected]#$%

Thank you in advance :slight_smile:
Curtis

HI

this is the correct css you must use:

.page-id-12 #header {
background-image: url(“http://lorempixel.com/400/200.jpg”) !important;
}

it’s important to end image path with image extension .jpg or .png otherwise it will not work

if you want to enable featured image as a header bg image you have to enable it from appearance > customize > general options > header

Thanks, I swear I had already looked at appearance > customize > general options > header… but apparently not. Thank you for the help :slight_smile:

Curtis

hi Curtis

:slight_smile: that’s why we are here, is there anything else?

actually yes, I have the same (small) issue on both sites I use illdy. When selecting a color scheme, the hover color stays on default yellow instead of any other color I select. I go through Appearance -> Customize -> Colors and select a color scheme but it doesn’t reflect on www.swirlclt.com which currently has a hover color of teal selected but instead yellow shows up.

hi

I still need your admin details :slight_smile:

ERROR: Invalid username. Lost your password?

Sorry Noda, I jumped the gun and deleted the admin role right after you solved my header issue. I (re)created the admin role for you again, thank you in advance :slight_smile:

username - colorlib
email - [email protected]
password - [email protected]#$%

hi

Sorry, but i was not able to resolve the issue, but i just opened case for our developer and he will take care now:

No worries, I’m super thankful for having you take the time to review. Its a rather small issue that’s more annoying than troublesome so I’ve never thought to ask about a resolution. You have been incredibly helpful and I appreciate your assistance :slight_smile:

thank you for this words, that’s my inspiration for work :slight_smile:

If you’re happy with our service, don’t forget to rate us: [Illdy] Reviews | WordPress.org

I will keep this ticket opened,

Hi

I just want to inform everyone.
The live color update issue in the customizer is fixed in half fixed https://github.com/ColorlibHQ/illdy/issues/277 by mahendrapratap4022 · Pull Request #332 · ColorlibHQ/illdy · GitHub
and there is one more issue in epsilon-framework in

class-epsilon-control-color-scheme.php file.

line no 122
<i class="dashicons dashicons-arrow-down"/>
should be
<i class="dashicons dashicons-arrow-down"></i>

I have created the PR fixing the https://github.com/ColorlibHQ/illdy/issues/277 by mahendrapratap4022 · Pull Request #199 · WPChill/epsilon-framework · GitHub in epsilon-framework with the fix or anyone can fix this by just changing it directly.

Thanks
Colorlib Support

Thanks @mahendra.pratap4022 :slight_smile: