Shapely Companion Plugin Error

When I install and activate the Shapely Companion Plugin as instructed in the Shapely Theme Documentation, I get this error:

Parse error: syntax error, unexpected ‘[’ in /hermes/walnaweb01a/b773/moo.smartfitchickscom/wp-content/plugins/shapely-companion/inc/widgets/widget-home-clients.php on line 84

Apparently I cannot move forward with setting up the theme without this plugin. How do I fix this issue?

Thank you!

Hello there,

I hope you are doing well today.

Please deactivate an third party plugins that you may have active now and then try to install the plugin with the theme activated.

Please update me on the results.

Best Regards,
Support

Hey I’m having the same problem today too. I just downloaded a theme and need to change the front page but I can’t because the companion plug-in seems to be angry at me. I just deactivated all other editing plug-ins and it’s still not working.

Here’s the error message:

Fatal error: Class ‘Epsilon_Editor_Custom_Control’ not found in /home/janvan81/nursescan.com/wp-content/plugins/illdy-companion/illdy-companion.php on line 345

Thank you!

Hey there,
Hope you’re doing well today

Kindly provide us with some temporary admin access to your site. We’ll be in a better position to spot anything suspicious from here.

You can add new users by going to Users > Add New set the user and password for us, set the role to admin and set the info here. You can navigate here for more details; Adding New Users to Your WordPress Site – Make WordPress Support.

I look forward to your reply :slight_smile:

Best Regards,
Support

Hi,

Thanks I will. What email should I use for you?

Hello there,

I hope you are doing well today.

We would not have an email for you to use however you can make the user account without an email address.

Best Regards,
Support

Ok! Here is the info. Thank you!

Username: Support

Password: FgjOXX8z0W2*[email protected]^s

Hello,
I have provided temporary admin access and have not heard anything back from the support team. Please provide an update soon or I will need to remove the admin access.

Thank you.

Hi @smartfitchicks2017
I hope you’re doing well today.

Unfortunately, I’m not seeing the credentials in the thread. Could you please privately copy and paste them here for me?

I look forward to your reply :slight_smile:

Hi @coates20s, I’m getting a white screen on your site. I’m going to ask that you log into your site’s FTP and go to wp-content/themes/ and rename the shapely folder to shapely_old, and do the same to the Shapely companion plugin in wp-content/plugins/

Please let me know if you have access to your site after that.

Best Regards,
Support

smartfitchicks.com/wp-admin

username: colorlib
password: GZphKO$4XnQ1mr9b!SMH9TlB

how do I log onto my sites ftp? The white screen happened just a couple of minutes ago and I’m freaking out! My Wordpress site isn’t hosted on my server.

Hey again

@coates20s, You’ll need to log into the server where your site is hosted in order to access your WordPress files. Are you aware of what company your site is hosted on? Once you are, then you should have an email with the credentials from them etc.
Your work has not been deleted (it may look that way), but all you need to do is go into your themes and plugins folder and rename the plugin and theme as was instructed earlier and you will regain access.

@smartfitchicks2017, Could you provide me with some FTP access to your site? Alternatively, you could log in for yourself and go to the /wp-content/plugins/ folder and remove the Shapely Companion plugin. I went ahead and activated the plugin to see what happens for myself and I got locked out, sorry about that. That was my bad.

From what I’m seeing I’m thinking the issue may be related to the version of PHP that you’re running. I’m running version 7 on my testing site and it works pretty well, version 5.6 is usually okay as well. Once that’s cleared up I’ll be able to go back in and take a proper look

I look forward to your reply :slight_smile:

Best Regards,
Support

I have removed the shapely companion plugin from the ftp file manager.

Hi @smartfitchicks2017,

Did you check on your PHP and attempt to update it?
That seems to have solved the issue for somebody else on another post.

Please try that and let me know.

I look forward to your reply :slight_smile:

Best Regards,
Support

Hello. I just updated the PHP to version 7. There is also an option to use version 7.1. Should I use that one instead?

I was able to download and activate the plugins with the updated PHP. I also updated to the newest version of Wordpress, but the dashboard does not seem to be compatible with the new PHP. Any action I take in the Dashboard goes to a white screen.

Hello there,

I hope you are doing well today.

In this case you would have to revert back to PHP version 5.6 or 7.0 which can be done by your hosting provider, depending on your hosting provider you will have to contact them for instructions on reverting to a previous PHP version.

Best Regards,
Support

I’m experiencing the same issue - it appears to be related to PHP version. My site is hosted on GoDaddy and the hosting plan I’m on only allows PHP versions 5.3 and 5.4 (I am on 5.3). I would not be able to upgrade my PHP without changing my hosting plan.

I had to use a Linux shell to remove the Shapely Companion so the site would load.

Is there any thought to tweaking Shapely Companion to make it reverse-compatible with some older PHP versions?

Best regards,
Shawn.