Shapely theme with Visual Composer's post grid


I’m I’m using the Shapely theme along with the Virtual Composer plugin. When I try to use Visual Composer’s post grid element, it doesn’t display any of the posts. I tried testing it with the Twenty Fifteen theme and everything shows up properly, so I’m thinking it’s something with the Shapely theme.

If anyone has any fixes or tips on where to begin with fixing this, I’d appreciate it.


Hi @yvnuwah,

I hope you are well today and thank you for your question.

Could you please share me the page URL from your site where it is not displaying so that i can troubleshoot it?

Kind Regards,

Hi Movin,

I can’t share it because it’s running on my local machine.

This can be due to plugin conflict on your site so please try temporary deactivating all plugins except Virtual Composer plugin and see whether everything works fine and then enable the plugins one by one to see which plugin is conflicting if any.

Can you check the JavaScript console for errors on Visual Composer’s post?

In Chrome go to “Tools -> Developer Tools” and in Firefox you can go to “Tools -> Web Developer -> Console”

Find information about how to open JavaScript browser console :

Let me know what JavaScript errors if any you are getting when you face this issue.

Yes. I’m getting an error that says the following:

TypeError: $(...).flexslider is not a function

I’m also including a screenshot of this in case that helps

Oh, and I forgot to mention, I deactivated every plugin except Visual Composer, but that ended up not being the problem.

I did some more googling and used the answer you gave HERE and it worked.

Unless there is a better and more recent solution, I think we can consider this problem solved.

Thanks for your help; I really appreciate it!

You are most welcome here :slight_smile:

You can just use that solution or use the latest version of Shapely theme by downloading it from here