Show full post/read more

I’ve been fiddling with this for a while now so thought I’d post here.

I have “Show post excerpts?” turned off and no excerpts set for any of my posts. In my post I positioned a ‘read-more’ line but this doesn’t seem to be replicated on the blog - an ‘arbitrary’ place in the text seems to be chosen for the cutoff.

Any ideas?

Blog is @ www.tomarcher.co.uk

Additionally, after the first two posts, subsequent posts get ‘shrunk down’. Is there any way to customise this? I.e. have more full sized posts, or no ‘shrunk down’ posts at all?

To show the full-width posts I changed the stylesheet to:

@media (min-width: 768px) {
    .article-container{
        overflow: hidden;
    }
    .blog.home article.post {
        width: 100%; /*50%*/
        /*margin: 0;*/
        /*padding-right: 10px;*/
        padding: 0!important;/*new*/
        display: inline-block;
        float: left;
    }
    .blog.home article.post .read-more, .blog.home article.post .entry-footer{
        display: block; /*none*/
    }

    .blog.home article.post: .post-inner-content{
        padding: 50px 0;
        margin-bottom: 30px;
    }

    .blog.home article.post:first-child .post-inner-content{
        padding: 0 0 50px;
    }

    .blog.home article.post:nth-child(odd) .post-inner-content , .blog.home article.post:nth-child(even) .post-inner-content{
        border-bottom: 1px solid #dedede;
    }

    .blog.home article.post:last-child .post-inner-content {
        border : 0;
    }

Hope this is correct. Still looking for a solution to get the 'read-more’s working properly.

Currently having issues with featured images. Got posts each with a different image (tho they’re roughly the same size when I upload). When viewed on the blog they’re vastly different sizes, with the smaller one looking like it’s not being styled in CSS the same way?

Edit: Turns out I fixed it by just deleting the offending larger image and reuploading.

Hi @tomm,

I hope you are well today and thank you for your question.

Still looking for a solution to get the ‘read-more’s working properly.

I can see the read more button on your shared site is working correctly as shown in the attached screenshot.

Please advise.

Also to help us keep support thread separates could you please create new thread for your other questions here https://colorlibsupport.com/c/activello/ instead of asking them in your single thread as it makes the thread messy and hard to read.

If you want to you can also add reference of this thread in your newly created thread.

We would be more than happy to help you on your new thread.

Best Regards,
Movin

Hi, while the ‘read more’ link does appear on the front page, it doesn’t appear at the position in the post that I placed it in the editor.

For both those post I’ve placed the ‘read more’ tag at the end of a full paragraph but on the front page it interrupts the text part way through a sentence.

This is working fine for me by unchecking the theme option “Show post excerpts?” as shown in the attached screenshots.

Would you mind if i log in to your site and do some troubleshooting? If this is ok then could you please share me your site log in details privately by checking the option “Set as private reply” when replying to this topic?

Maybe I have too much text before the ‘read-more’?

Anyway here’s the login details:
User: Tom
Pass: JLjUyjtD5PzTfRcgA!UeeTaw

Maybe I have too much text before the ‘read-more’?

Yes you are right. That is why it is working foe some posts and not for others having too much text before the ‘read-more’.

If you have too much text before the ‘read-more’ then add that text in the excerpt field of that post so that whole content will be displayed.