Sidebar not appearing on Blog & Single Blog Pages

Please see http://m2hpartners.com

I have added this shortcode in the custom css : }
/removes all sidebar from pages but leaves them on blog/ .page aside#secondary {

display: none;
} .page div#primary{

width:100% !important;
}

I just want the sidebar to show up on the right side of the main blog page & the single blog pages, but with this shortcode it is not showing up properly.

I can email you my list of what all I have in the custom ccs - I removed it all and it popped up, but if you can spot what it inhibiting this from working, that might be a better option than removing each code and seeing what does the trick without messing up all the other settings. The setting that is in there is likely to have full page width on every page.

Thank you for your help, always appreciated! :slight_smile:

-Stacey

Hey there,
I hope you’re doing well today

Just to confirm, when you remove all the custom coding you currently have the sidebar appears?
If so, you can send the custom coding you have let us have a look at it for you.

Best Regards,
Support

Hi,

You want to show the sidebar in the blog page and single blog post pages? In that case use this Custom CSS in Appearance -> Customize -> Additional CSS,

.blog #secondary, .single-post #secondary {
    display: block;
}

If that didn’t work, remove that and add this,

.blog #secondary, .single-post #secondary {
    display: block !important;
}

Let us know,

Thanks,
laranz.