Slider images shrunken

I’m just in the process of setting up my blog, I had only put out a couple of posts and was beginning to play with images and get thing looking better.

everything was working well, i had changed all my image sizes to work better in the theme, got the slider working correctly, it was starting to look good.

then all of a sudden about 2 days ago i logged in and my slider images were shrunken. it’s also seeming to move the slider up into the headers area, but behind the header itself.

i tried removing and re-adding the images, i tried changing the theme to something else and back again. nothing i do seems to fix it.

any suggestions on what I can do?

my site is if you want to take a look

thanks for the help

Hi @makari,

I hope you are well today and thank you for your question.

You can try resolving this by adding the following CSS code in the Custom CSS option of the latest version of Sparkling theme on the below path.

Admin Area -> Appearance -> Customize -> Sparkling Options -> Other -> Custom CSS

#page .flexslider .slides img {
    width: 100%;

Best Regards,

would that set all the slider images to never scale? just curious so i know what I’m doing

also do we have any clue what’s causing this? the slider issue stays the same even when i change to other themes

Thanks for the help,

Hi Movin,

I’m having the same issue ever since the latest WP update. My slider images aren’t filling the whole browser width. I put in the CSS you recommended above and that helped the image fill the space, but now I’m realizing that the image the slider is calling isn’t the full width image I uploaded. It appears to be upscaled. It seems like the latest WP update might have done something with how the “featured image” loads?

For now I have disabled the slider, but it might be a bigger issue that needs to be addressed in a future Sparkling theme update.


God guys… Is it really so hard to check previous topics or use search feature?

tl;dr - disable Photon module in Jetpack - it’s causing the problems after the last update.

… because that topic title described my issue so well… God guy… you don’t need to be rude about it. Nonetheless… thanks for the info.

yeah i didnt look at that because my issue had nothing to do with mobile devices

i did check other slider issue posts that seemed unrelated

thanks though

Disabling Photon fixed my issue.

Guys seriously… There are already like 5 or 6 topics about the issue. Not everyone titled “mobile”. You are just lazy :wink:

Hi There,

As said it seems it is happening because of the Jetpack plugin so could you please try temporary deactivating it or its Photon module on your site if you are using it?

It seems this jetpack module is not updating the images stored on so to resolve the issue either disable this module or update the images on by contacting jetpack support team.

Please make sure your set slider images are at least in size 1290px X 400px so that it will display as shown on the demo site

Also use the plugin Regenerate Thumbnails – WordPress plugin | to regenerate thumbnail images.

After doing this if you are still facing the issue with it then to help us keep support thread separates could you please create your own thread for your question here instead of replying on others thread as it makes the thread messy and hard to read.

If you want to you can also add reference of this thread in your newly created thread.

We would be more than happy to help you on your new thread.