Slider not working for Sparkling WordPress theme

I’ve recently installed the sparkling theme, and have set up the category and options for the slider, but it doesn’t show. My news from the selected category appears in the post list but i can’t find any way to “activate” the slider.

I would consider other sliders but i like the simple idea of the slider taking news from a category and also posting the title over the slide itself.

There is no further information on the support forum or documentation for this problem, I’ve checked. Today, WordPress updated itself to 4.2 and i was hoping this would fix the problem but it hasn’t.

Hi, I’m no expert, but did you set featured images for the category that you chose for the slider?

The one and only thing that could be missing are featured images that are used inside slider. For more information on how to use featured images for posts you can check official WordPress documentation.


I have a few problems too.

  1. The slider isn’t working. I have done everything you have specified in the forums and in the discussions. The featured images are set. The “blog” is chosen as the category and the box is checked to allow the slider in the Theme options. However, I still don’t see it on or on

  2. I have chosen a static page as the home page. a) Can the slider appear on this page at the very top? b) Is there a way to remove the “Home” title from the page? It is showing on the page and looks very strange.

  3. I have added the slider shortcode to the “home” page but it isnt showing. It was showing yesterday but now its gone. I have removed and re-inserted it but it still isnt showing.


  1. Please disable completely all plugins to see if this resolved this issue. Slider will be displayed on front page and it doesn’t matter is static page or blog is being used on that page.

  2. You can hide title from homepage by adding this simple CSS to Appearance >> Theme Options >> Other >> Custom CSS.

.page-id-1182 .entry-header {
  display: none;

  1. There is no shortcode for slider for this theme. What code you were trying to use?

This is the shortcode.(attached screenshot).

The Jetpack plugin is causing the issue with the slider. Both within the post and on the main page. What should I do?

If you look at the site now, you’ll see I created blank posts with the images I want to appear on the home page. But the slides link back to those blank pages. Is it possible to change those links to link to landing pages? Or to add images to the slider from pages instead of posts?

(P.S. This is the BEST free website I have worked with so far and I have tried several. Thank you for your hard work.)


You can remove link from slider completely by following this guide.

Also you can use plugin such as this one to link these blank posts to anywhare you want and they are no longer be visible by visitors.

Thank you. What do I do about Jetpack conflicting with the slider?

I’m having trouble as well. Here’s what I posted in the WP support forums:

I’ve enabled the homepage slider under Appearance>>Theme Options and set the category to “Featured” and to display 3 items. It’s not showing up. I have Photon enabled in Jetpack if that matters.

I have noticed using Inspect Element that it does seem like there’s stuff in the top-section, but it’s not showing up. The images it references are the non-photon however.

Website is here:

The featured images are:, and

@mapshole Have you tried disabling Jetpack? That worked for me.

But I do need Jetpack. Waiting for @Aigars to get back to me about that.

So I disabled Gravatar Hovercards in Jetback and it made the slider take up the entire screen and it showed them in all the wrong sizes. I archived it because I didn’t want to leave my page looking like that: Mapshole: Uncommon Knowledge

Is there a way to get that working so they’re all one size?

@mapshole Yay. It was the Gravatar hovercards messing with the slider.

About your images, I’m using images that are 1920 x 550. Basically, aspect ratio of 192:55. That seems to be the ideal size for slider images. Maybe try that?


Slider on your website is not working because of WP Minify Fix plugin that you have installed. Not all plugin JavaScript files can be minified and combined together because it might result in conflicts like you have now. Make sure to debug by combining different files and excluding some to see what can and cannot be combined together. If you don’t know how to do it just disable this plugin completely as there is no one size fits all solution when it comes to minifications.

So I disabled Hover cards and that worked. I kind of want to change the background on the slides to the grey of the rest of the page however. How can I do that?


You can change background for slider to the same color as the rest of website by adding this simple CSS to Appearance >> Theme Options >> Other >> Custom CSS.

.flexslider {
    background: #F2F2F2;

I’m apparently having much the same challenges with my slider not appearing. The jpes I’m using are fairly lightweight, and I’ve been disabling a lot of plugins (although quite randomly without knowing what else to do).

Any guesses to what plugins might cause the problem?

I am using jetpack, but many features, including jetpack hovercards, are disabled, so they shouldn’t cause a problem.

Any help would be much appreciated.

Cheers Kenny


  1. This thread is marked as resolved.
  2. This thread is related to Sparkling theme.
  3. Slider appears to be working perfectly fine on your website.

IF you need any further assistance with slider for Dazzling theme, please start your own thread and we will help you from there.

Sorry for inconvenience.