Stop Featured Image displaying in posts


How do I stop the featured image displaying in a post? I only want it to display on the categories page.

This looks really terrible!

Hi @digitalnomads,

I hope you are well today and thank you for your question.

You can try achieving this by adding the following CSS code in the Custom CSS option of the latest version of Sparkling theme on the below path.

Admin Area -> Appearance -> Customize -> Sparkling Options -> Other -> Custom CSS

body.single-post img.single-featured.wp-post-image {
    display: none;

Best Regards,

Hello Movin,
thanks for this info. It does work fine on the page of a single article, but not on the home page. There I still get the featured image on front of every article teaser. Any idea to get rid of it here also!? Thanks a lot!

@suitbert to make it work also on home page of the site try using the below CSS code instead.

body.home article img.single-featured.wp-post-image,
body.single-post img.single-featured.wp-post-image {
    display: none;